summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/plwm/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/plwm/files')
-rw-r--r--x11-wm/plwm/files/plwm-2.5-destdir.patch33
-rw-r--r--x11-wm/plwm/files/plwm-2.5-pep0263.patch8
-rw-r--r--x11-wm/plwm/files/plwm-2.5-python2.5.patch21
-rw-r--r--x11-wm/plwm/files/plwm-2.6_alpha-pep0263.patch17
-rw-r--r--x11-wm/plwm/files/plwm-2.6_alpha-python2.5.patch21
-rw-r--r--x11-wm/plwm/files/plwm-2.6_alpha.patch27
-rw-r--r--x11-wm/plwm/files/plwm-2.7_rc1-pep0263.patch17
7 files changed, 144 insertions, 0 deletions
diff --git a/x11-wm/plwm/files/plwm-2.5-destdir.patch b/x11-wm/plwm/files/plwm-2.5-destdir.patch
new file mode 100644
index 000000000000..8bcd01511731
--- /dev/null
+++ b/x11-wm/plwm/files/plwm-2.5-destdir.patch
@@ -0,0 +1,33 @@
+diff -ur plwm-2.5.orig/Makefile.in plwm-2.5/Makefile.in
+--- plwm-2.5.orig/Makefile.in 2007-06-29 13:30:28.000000000 +0200
++++ plwm-2.5/Makefile.in 2007-06-29 14:07:42.000000000 +0200
+@@ -24,19 +24,16 @@
+ all:
+
+ install:
+- -$(INSTALL) -d $(bindir)
+- -$(INSTALL) -d $(PLWM_PATH)
+- $(INSTALL) -m 644 $(PLWM_MODULES) $(PLWM_PATH)
+- echo >> $(PLWM_PATH)/__init__.py
+- echo "__version__ = '$(VERSION)'" >> $(PLWM_PATH)/__init__.py
+- echo >> $(PLWM_PATH)/__init__.py
+-
+-# Compile .pyc and .pyo-files
+- $(PYTHON) -c 'import sys; sys.path.insert(0, "$(PYTHON_SITE_PATH)"); import plwm.xlibpath; from plwm import *'
+- $(PYTHON) -O -c 'import sys; sys.path.insert(0, "$(PYTHON_SITE_PATH)"); import plwm.xlibpath; from plwm import *'
+- ./install-plwm.sh "$(PLWM)" $(bindir)/plwm
+- ./install-plwm.sh "$(WMM)" $(bindir)/wmm
+- ./install-plwm.sh "$(INSPECT_PLWM)" $(bindir)/inspect_plwm
++ -$(INSTALL) -d $(DESTDIR)$(bindir)
++ -$(INSTALL) -d $(DESTDIR)$(PLWM_PATH)
++ $(INSTALL) -m 644 $(PLWM_MODULES) $(DESTDIR)$(PLWM_PATH)
++ echo >> $(DESTDIR)$(PLWM_PATH)/__init__.py
++ echo "__version__ = '$(VERSION)'" >> $(DESTDIR)$(PLWM_PATH)/__init__.py
++ echo >> $(DESTDIR)$(PLWM_PATH)/__init__.py
++
++ ./install-plwm.sh "$(PLWM)" $(DESTDIR)$(bindir)/plwm
++ ./install-plwm.sh "$(WMM)" $(DESTDIR)$(bindir)/wmm
++ ./install-plwm.sh "$(INSPECT_PLWM)" $(DESTDIR)$(bindir)/inspect_plwm
+
+ clean:
+
diff --git a/x11-wm/plwm/files/plwm-2.5-pep0263.patch b/x11-wm/plwm/files/plwm-2.5-pep0263.patch
new file mode 100644
index 000000000000..ae4562d42073
--- /dev/null
+++ b/x11-wm/plwm/files/plwm-2.5-pep0263.patch
@@ -0,0 +1,8 @@
+diff -ur plwm-2.5.orig/plwm/mw_apm.py plwm-2.5/plwm/mw_apm.py
+--- plwm-2.5.orig/plwm/mw_apm.py 2007-08-27 15:02:46.000000000 +0200
++++ plwm-2.5/plwm/mw_apm.py 2007-08-27 15:04:01.000000000 +0200
+@@ -1,3 +1,4 @@
++# -*- coding: utf-8 -*-
+ # $Id: mw_apm.py,v 1.4 2001/10/18 09:36:52 petli Exp $
+ #
+ # mw_apm.py -- display APM status in a modewindow
diff --git a/x11-wm/plwm/files/plwm-2.5-python2.5.patch b/x11-wm/plwm/files/plwm-2.5-python2.5.patch
new file mode 100644
index 000000000000..334ac94850eb
--- /dev/null
+++ b/x11-wm/plwm/files/plwm-2.5-python2.5.patch
@@ -0,0 +1,21 @@
+diff -ur plwm-2.5.orig/plwm/inspect.py plwm-2.5/plwm/inspect.py
+--- plwm-2.5.orig/plwm/inspect.py 2007-06-29 13:30:28.000000000 +0200
++++ plwm-2.5/plwm/inspect.py 2007-06-29 14:36:43.000000000 +0200
+@@ -23,7 +23,7 @@
+ import sys
+ import traceback
+ import struct
+-import whrandom
++import random
+ import cStringIO
+
+ InspectFileEventType = event.new_event_type()
+@@ -75,7 +75,7 @@
+ # portnumber in a property on screen 0
+
+ addr, port = self.inspect_socket.getsockname()
+- self.inspect_cookie = whrandom.randint(0, 0x7ffffffe)
++ self.inspect_cookie = random.randint(0, 0x7ffffffe)
+
+ self.default_screen.root.change_property(self.PLWM_INSPECT_SERVER,
+ self.PLWM_INSPECT_SERVER,
diff --git a/x11-wm/plwm/files/plwm-2.6_alpha-pep0263.patch b/x11-wm/plwm/files/plwm-2.6_alpha-pep0263.patch
new file mode 100644
index 000000000000..62d04e7d0fd9
--- /dev/null
+++ b/x11-wm/plwm/files/plwm-2.6_alpha-pep0263.patch
@@ -0,0 +1,17 @@
+diff -ur PLWM-2.6a.orig/examples/hrwwm.py PLWM-2.6a/examples/hrwwm.py
+--- PLWM-2.6a.orig/examples/hrwwm.py 2007-08-27 15:06:29.000000000 +0200
++++ PLWM-2.6a/examples/hrwwm.py 2007-08-27 15:07:33.000000000 +0200
+@@ -1,4 +1,5 @@
+ #!/usr/bin/env python
++# -*- coding: utf-8 -*-
+ #
+ # hrwwm.py -- Example PLWM window manager "configuration"
+ #
+diff -ur PLWM-2.6a.orig/plwm/mw_apm.py PLWM-2.6a/plwm/mw_apm.py
+--- PLWM-2.6a.orig/plwm/mw_apm.py 2007-08-27 15:06:29.000000000 +0200
++++ PLWM-2.6a/plwm/mw_apm.py 2007-08-27 15:07:00.000000000 +0200
+@@ -1,3 +1,4 @@
++# -*- coding: utf-8 -*-
+ # $Id: mw_apm.py,v 1.4 2001/10/18 09:36:52 petli Exp $
+ #
+ # mw_apm.py -- display APM status in a modewindow
diff --git a/x11-wm/plwm/files/plwm-2.6_alpha-python2.5.patch b/x11-wm/plwm/files/plwm-2.6_alpha-python2.5.patch
new file mode 100644
index 000000000000..af22a96504a9
--- /dev/null
+++ b/x11-wm/plwm/files/plwm-2.6_alpha-python2.5.patch
@@ -0,0 +1,21 @@
+diff -ur PLWM-2.6a.orig/plwm/inspect.py PLWM-2.6a/plwm/inspect.py
+--- PLWM-2.6a.orig/plwm/inspect.py 2007-06-29 14:40:54.000000000 +0200
++++ PLWM-2.6a/plwm/inspect.py 2007-06-29 14:41:25.000000000 +0200
+@@ -23,7 +23,7 @@
+ import sys
+ import traceback
+ import struct
+-import whrandom
++import random
+ import cStringIO
+
+ InspectFileEventType = event.new_event_type()
+@@ -75,7 +75,7 @@
+ # portnumber in a property on screen 0
+
+ addr, port = self.inspect_socket.getsockname()
+- self.inspect_cookie = whrandom.randint(0, 0x7ffffffe)
++ self.inspect_cookie = random.randint(0, 0x7ffffffe)
+
+ self.default_screen.root.change_property(self.PLWM_INSPECT_SERVER,
+ self.PLWM_INSPECT_SERVER,
diff --git a/x11-wm/plwm/files/plwm-2.6_alpha.patch b/x11-wm/plwm/files/plwm-2.6_alpha.patch
new file mode 100644
index 000000000000..2a4fd8bc3b0f
--- /dev/null
+++ b/x11-wm/plwm/files/plwm-2.6_alpha.patch
@@ -0,0 +1,27 @@
+--- utils/wmm_orig.py 2001-11-26 13:48:21.000000000 +0000
++++ utils/wmm.py 2004-06-04 14:21:41.228567568 +0100
+@@ -38,10 +38,6 @@
+
+ import sys
+ import os
+-###SETUP PATH
+-sys.path[1:1] = [os.path.join(sys.path[0], '..')]
+-import plwm.xlibpath
+-###END SETUP PATH
+
+ from Xlib import display, rdb, X, Xutil
+ import string
+
+--- utils/inspect_plwm_orig.py 2001-01-17 15:28:30.000000000 +0000
++++ utils/inspect_plwm.py 2004-06-04 14:21:30.148252032 +0100
+@@ -22,10 +22,6 @@
+
+ import sys
+ import os
+-###SETUP PATH
+-sys.path[1:1] = [os.path.join(sys.path[0], '..')]
+-import plwm.xlibpath
+-###END SETUP PATH
+
+ from Xlib import display, rdb
+ import readline
diff --git a/x11-wm/plwm/files/plwm-2.7_rc1-pep0263.patch b/x11-wm/plwm/files/plwm-2.7_rc1-pep0263.patch
new file mode 100644
index 000000000000..aadc8f86f458
--- /dev/null
+++ b/x11-wm/plwm/files/plwm-2.7_rc1-pep0263.patch
@@ -0,0 +1,17 @@
+diff -ur PLWM-2.7rc1.orig/examples/hrwwm.py PLWM-2.7rc1/examples/hrwwm.py
+--- PLWM-2.7rc1.orig/examples/hrwwm.py 2007-08-27 15:06:29.000000000 +0200
++++ PLWM-2.7rc1/examples/hrwwm.py 2007-08-27 15:07:33.000000000 +0200
+@@ -1,4 +1,5 @@
+ #!/usr/bin/env python
++# -*- coding: utf-8 -*-
+ #
+ # hrwwm.py -- Example PLWM window manager "configuration"
+ #
+diff -ur PLWM-2.7rc1.orig/plwm/mw_apm.py PLWM-2.7rc1/plwm/mw_apm.py
+--- PLWM-2.7rc1.orig/plwm/mw_apm.py 2007-08-27 15:06:29.000000000 +0200
++++ PLWM-2.7rc1/plwm/mw_apm.py 2007-08-27 15:07:00.000000000 +0200
+@@ -1,3 +1,4 @@
++# -*- coding: utf-8 -*-
+ #
+ # mw_apm.py -- display APM status in a modewindow
+ #