summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-19 23:03:31 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-19 23:03:31 +0100
commit087f275d574e0f8b1eace5c99d9f4dd85c518739 (patch)
tree51062d44a6ceef5cc7ece5a692259dccd1af8117 /x11-themes/constantine-backgrounds/constantine-backgrounds-12.1.1.4-r2.ebuild
parentx11-themes/commonbox-styles-extra: update EAPI 6 -> 8 (diff)
downloadgentoo-087f275d574e0f8b1eace5c99d9f4dd85c518739.tar.gz
gentoo-087f275d574e0f8b1eace5c99d9f4dd85c518739.tar.bz2
gentoo-087f275d574e0f8b1eace5c99d9f4dd85c518739.zip
x11-themes/constantine-backgrounds: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes/constantine-backgrounds/constantine-backgrounds-12.1.1.4-r2.ebuild')
-rw-r--r--x11-themes/constantine-backgrounds/constantine-backgrounds-12.1.1.4-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-themes/constantine-backgrounds/constantine-backgrounds-12.1.1.4-r2.ebuild b/x11-themes/constantine-backgrounds/constantine-backgrounds-12.1.1.4-r2.ebuild
new file mode 100644
index 000000000000..54fad80ba489
--- /dev/null
+++ b/x11-themes/constantine-backgrounds/constantine-backgrounds-12.1.1.4-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm
+
+MY_P="${PN}-$(ver_cut 1-3)"
+
+DESCRIPTION="Fedora 12 official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F12_Artwork"
+SRC_URI="https://archives.fedoraproject.org/pub/archive/fedora/linux/development/15/source/SRPMS/${PN}-$(ver_rs 3 -).fc15.src.rpm"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="CC-BY-SA-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+src_unpack() {
+ rpm_src_unpack
+
+ # as of 2017-07-28 rpm.eclass does not unpack the further lzma
+ # file automatically.
+ unpack ./${MY_P}.tar.lzma
+}
+
+src_compile() { :; }
+
+src_test() { :; }
+
+src_install() {
+ # The install targets are serial anyway.
+ emake -j1 DESTDIR="${D}" install
+}