summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-26 21:18:16 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-26 21:20:23 +0200
commitcebdc9adb544bc85147532b98252abaefcfa8275 (patch)
tree034c22fb5fca57203bdd082f478d28ba94362dbe /x11-themes/chameleon-xcursors
parentx11-themes/pearlgrey-xcursors: drop old version (diff)
downloadgentoo-cebdc9adb544bc85147532b98252abaefcfa8275.tar.gz
gentoo-cebdc9adb544bc85147532b98252abaefcfa8275.tar.bz2
gentoo-cebdc9adb544bc85147532b98252abaefcfa8275.zip
x11-themes/chameleon-xcursors: fix HOMEPAGE
Also slightly overhauled ebuild. Bug: https://bugs.gentoo.org/758236 Closes: https://bugs.gentoo.org/680600 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-themes/chameleon-xcursors')
-rw-r--r--x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r2.ebuild35
-rw-r--r--x11-themes/chameleon-xcursors/metadata.xml17
2 files changed, 44 insertions, 8 deletions
diff --git a/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r2.ebuild b/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r2.ebuild
new file mode 100644
index 000000000000..435e7cda0663
--- /dev/null
+++ b/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+COLOURS=( "Anthracite" "DarkSkyBlue" "SkyBlue" "Pearl" "White" )
+MY_PN="Chameleon"
+
+DESCRIPTION="Style neutral scalable cursor theme"
+HOMEPAGE="https://store.kde.org/p/999948/"
+for COLOUR in "${COLOURS[@]}"; do
+ SRC_URI="${SRC_URI} mirror://gentoo/${MY_PN}-${COLOUR}-${PV}.tar.bz2"
+done
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="x11-libs/libXcursor"
+
+src_install() {
+ dodir /usr/share/cursors/xorg-x11/
+
+ for COLOUR in "${COLOURS[@]}"; do
+ for SIZE in Large Regular Small; do
+ local name="${MY_PN}-${COLOUR}-${SIZE}"
+ rm "${WORKDIR}"/${name}-${PV}/{COPYRIGHT,LICENSE} || die
+ insinto /usr/share/cursors/xorg-x11/${name}
+ doins -r "${WORKDIR}"/${name}-${PV}
+ done
+ done
+}
diff --git a/x11-themes/chameleon-xcursors/metadata.xml b/x11-themes/chameleon-xcursors/metadata.xml
index 6d792b262e9b..619d7563cc5a 100644
--- a/x11-themes/chameleon-xcursors/metadata.xml
+++ b/x11-themes/chameleon-xcursors/metadata.xml
@@ -1,12 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>gentoo@aisha.cc</email>
- <name>Aisha Tammy</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
</pkgmetadata>