summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-08-17 07:15:47 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-08-17 07:24:40 -0400
commitea1f8be101b25cf08dfbc7b7095d15c7b4de42b2 (patch)
tree90649b1995867398f266b7849d158d6bc1e939b4 /x11-terms
parentx11-terms/kitty-terminfo: add 0.36.0 (diff)
downloadgentoo-ea1f8be101b25cf08dfbc7b7095d15c7b4de42b2.tar.gz
gentoo-ea1f8be101b25cf08dfbc7b7095d15c7b4de42b2.tar.bz2
gentoo-ea1f8be101b25cf08dfbc7b7095d15c7b4de42b2.zip
x11-terms/kitty: add 0.36.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.36.0.ebuild187
2 files changed, 190 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 04c1e486d121..24da27d2c250 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -4,3 +4,6 @@ DIST kitty-0.34.1.tar.xz.sig 566 BLAKE2B fb01069e33f958bfc1aee3e42ab5d8d775d79cf
DIST kitty-0.35.2-vendor.tar.xz 1558376 BLAKE2B be02d81411e8549afa81f1f84f05fbc9f9aef8b634bb5572f4301721b25b18c22381e5d8d9ab724cd98e5aee45ac58c338b56e69813cc5d38b6ec1eb39c2b3fb SHA512 bd1ecd57b7a29bbc391fcc093c3a92223656422ee7726815f07015bfd9fd829118570d8177c19867a3e6a200d1f5ba73919e7a7639584d1bfcae21853c3d7140
DIST kitty-0.35.2.tar.xz 8220608 BLAKE2B 277803c7036890af34f2e0497ab1d33cb578cba4bfba425d6699e02e2106cde4e10f7dcc6859ce7eea1b4f34795a2f5180328665450ccb49d8a6da4183fa4f50 SHA512 edc78046f942965c823a1202a6d7c85cc2d2acb376824a0f5224d4ba6f48ed0978a00eb7a3e1e6053622a7d5fdcf80009ecfb61a63272cf407dd30f828f47b56
DIST kitty-0.35.2.tar.xz.sig 566 BLAKE2B 89e636f2fcd8ee12be37e41187d131d2092e667ec8b62a5ca1c745d8c5813e55c1d776cafa7d1b9ba7b6142f6bd9c204c6943f22ecc0236329a02912d767831c SHA512 bc3d6734012e81727494c5879f847a72e0a84263a9c156578260592b5ae55558b880315977c586e0f9c4845485d2a10ef414929fb3a12a27ae3248df46338bfc
+DIST kitty-0.36.0-vendor.tar.xz 1559096 BLAKE2B 11190ac82f4ba36dc3d27d1ec2b43c4ace682e2013a60cb0f8a8dbc9d9976b6be3ea9fbfc908d89e637876a0fca6df1884b1fbf97a5973835078e4e9ba22af11 SHA512 fdabacc31135f8377b31376389af921d52de2ffa393b75c5e3036bab2eebbdb7c8204a1251fb0393d8367a462b078345ad0809754550b3a8fdb8368b839e24ff
+DIST kitty-0.36.0.tar.xz 8850304 BLAKE2B 7070f1cd1f0dbdd11a91771c124d7278a4918f320b3f2bbc299cd1d5cab05e617761d97f2531736757788b130453de73951ee75a4d604ee99b8ef819080e58ac SHA512 910864d9f7d1015f42a641200a3bd3f8b682c108c6732a189098072e83bc263d53589e2dfb6e3383abc635f19d4476f3ab22bd24914c316416a8c9fd89d48b2f
+DIST kitty-0.36.0.tar.xz.sig 566 BLAKE2B e114f1b639fa564bffdc5595137df01dccb1b6f1102f6616ef206f0d5be20326b0c66e79a58525468b8a406b4c2701e79c7d03d4216404ee458da104cad0ed7d SHA512 71c9efcd45dd2a05afd26947a7379b45b479654bbf639abe8e20543b2bc233b891365b674502b9d076b9e56f5d8a6da2d79d8a2efd08093be3662a98da30f78e
diff --git a/x11-terms/kitty/kitty-0.36.0.ebuild b/x11-terms/kitty/kitty-0.36.0.ebuild
new file mode 100644
index 000000000000..9e678478d906
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.36.0.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit edo go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD BSD-2 MIT MPL-2.0" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )
+"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-fonts/symbols-nerd-font
+ media-libs/fontconfig
+ media-libs/harfbuzz:=[truetype]
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcursor
+ )
+ wayland? ( dev-libs/wayland )
+ !sci-mathematics/kissat
+"
+DEPEND="
+ ${RDEPEND}
+ amd64? ( >=dev-libs/simde-0.8.0-r1 )
+ arm64? ( dev-libs/simde )
+ x86? ( dev-libs/simde )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )
+"
+# bug #919751 wrt go subslot
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.22:=
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )
+"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/cflags.append(fortify_source)/pass/" # use toolchain's _f_s
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x -buildvcs=false"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc no-sudo"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ rm -r linux-package/share/terminfo || die # provided by kitty-terminfo
+
+ if [[ ${PV} == 9999 ]]; then
+ mkdir -p linux-package/share/doc/${PF} || die
+ else
+ mv linux-package/share/doc/{${PN},${PF}} || die
+ fi
+
+ # generate default config as reference, command taken from docs/conf.rst
+ if ! tc-is-cross-compiler; then
+ linux-package/bin/kitty +runpy \
+ 'from kitty.config import *; print(commented_out_default_config())' \
+ > linux-package/share/doc/${PF}/kitty.conf || die
+ fi
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ edo mv linux-package "${ED}"/usr
+
+ # kitty currently detects and copies the system's nerd font at build
+ # time, then uses that rather than the system's at runtime
+ dosym -r /usr/share/fonts/symbols-nerd-font/SymbolsNerdFontMono-Regular.ttf \
+ /usr/"$(get_libdir)"/kitty/fonts/SymbolsNerdFontMono-Regular.ttf
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ use X && optfeature "X11 startup notification support" x11-libs/startup-notification
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}