summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-23 20:10:04 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-06-26 23:53:06 +0200
commit08732702b792b2a51a0ccab1a2fed6d3ffe8c83d (patch)
tree4d32ddd1252067177d1f1b5c1fa61cd4cd993b66 /x11-plugins
parentx11-plugins/docker: use HTTPs (diff)
downloadgentoo-08732702b792b2a51a0ccab1a2fed6d3ffe8c83d.tar.gz
gentoo-08732702b792b2a51a0ccab1a2fed6d3ffe8c83d.tar.bz2
gentoo-08732702b792b2a51a0ccab1a2fed6d3ffe8c83d.zip
x11-plugins/docker: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/docker/docker-1.5-r2.ebuild29
-rw-r--r--x11-plugins/docker/files/docker-1.5-makefile_rename.patch4
2 files changed, 31 insertions, 2 deletions
diff --git a/x11-plugins/docker/docker-1.5-r2.ebuild b/x11-plugins/docker/docker-1.5-r2.ebuild
new file mode 100644
index 000000000000..8999156d944e
--- /dev/null
+++ b/x11-plugins/docker/docker-1.5-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Openbox app which acts as a system tray for KDE and GNOME2"
+HOMEPAGE="https://icculus.org/openbox/2/docker/"
+SRC_URI="https://icculus.org/openbox/2/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-makefile_rename.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ einfo "To avoid collision with app-emulation/docker, binary was renamed to wmdocker"
+}
diff --git a/x11-plugins/docker/files/docker-1.5-makefile_rename.patch b/x11-plugins/docker/files/docker-1.5-makefile_rename.patch
index 2e742661b11d..cf20a9135aa5 100644
--- a/x11-plugins/docker/files/docker-1.5-makefile_rename.patch
+++ b/x11-plugins/docker/files/docker-1.5-makefile_rename.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2015-01-19 20:10:47.762522964 +0100
-+++ Makefile 2015-01-19 20:11:11.463545692 +0100
+--- a/Makefile 2015-01-19 20:10:47.762522964 +0100
++++ b/Makefile 2015-01-19 20:11:11.463545692 +0100
@@ -5,12 +5,10 @@
#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#