summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-12-23 21:00:20 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-12-23 21:00:37 +0300
commit3bbe12d543637adc37c39faa6c53866db5222973 (patch)
treefa3df0582931da8084abb83b440d665372137b41 /x11-plugins/wmfrog
parentsys-devel/remake: Version bump (diff)
downloadgentoo-3bbe12d543637adc37c39faa6c53866db5222973.tar.gz
gentoo-3bbe12d543637adc37c39faa6c53866db5222973.tar.bz2
gentoo-3bbe12d543637adc37c39faa6c53866db5222973.zip
x11-plugins/wmfrog: Drop old (EAPI=2)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'x11-plugins/wmfrog')
-rw-r--r--x11-plugins/wmfrog/Manifest1
-rw-r--r--x11-plugins/wmfrog/files/01-fix-segfault-0.2.0.patch54
-rw-r--r--x11-plugins/wmfrog/files/02-buffer-overflow-0.2.0.patch60
-rw-r--r--x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild36
4 files changed, 0 insertions, 151 deletions
diff --git a/x11-plugins/wmfrog/Manifest b/x11-plugins/wmfrog/Manifest
index 526a3f94c5ee..e36da29c94e6 100644
--- a/x11-plugins/wmfrog/Manifest
+++ b/x11-plugins/wmfrog/Manifest
@@ -1,2 +1 @@
-DIST wmfrog-0.2.0.tgz 59113 BLAKE2B 39241240ee0477e8d587e634be74184c50b34078be329bab1786a0223395e76e6284693096fc0050ee6a32308dbe0b1f8540ead21c1c2509d158a1ff4b94b0c4 SHA512 e704600d2a3ce4ff64e4c5393ec4b977356ed18545b937102c2a120f6407f1b879f050a1a7f324c8ea40e2360dfb8147bf24e9910483aebb24a3f8e2692537f4
DIST wmfrog-0.3.1.tgz 128499 BLAKE2B 5bde4ccf41fda8e1a7e4fe9d40727e0d86d65830cc749955f5b1c97949c543f8f7253ddc6fffa48fc606e23c2ff6b4c66e07c66807a43e02f68961dfbb20d683 SHA512 35cd7da8ec0173f4799119191cd28befaed0fd5ea09c0dd2e9789ce37e9a1a4a83a9fb4562051a8da9c1449eafc8299c86914cb6f0e5bc35bd051560442af7ee
diff --git a/x11-plugins/wmfrog/files/01-fix-segfault-0.2.0.patch b/x11-plugins/wmfrog/files/01-fix-segfault-0.2.0.patch
deleted file mode 100644
index 7e88f49058ff..000000000000
--- a/x11-plugins/wmfrog/files/01-fix-segfault-0.2.0.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 7b9ead8d480eb2be07db646e9c6383f3397beaea Mon Sep 17 00:00:00 2001
-From: Jim Ramsay <lack@gentoo.org>
-Date: Thu, 6 Aug 2009 12:22:26 -0400
-Subject: [PATCH] Fixed segfault if Weather or Clouds not present
-
-Though the variables 'weatherFound' and 'cloudsFound' were being set properly by
-fscanf, their values were never actually checked.
-
-Furthermore, the strings (Weather, Clouds, tmp1 and tmp2) were not being
-initialized to NULL as the code seems to have been expecting.
----
- Src/wmFrog.c | 12 ++++++------
- 1 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/Src/wmFrog.c b/Src/wmFrog.c
-index e2d82af..af4101a 100644
---- a/Src/wmFrog.c
-+++ b/Src/wmFrog.c
-@@ -68,10 +68,10 @@ int n, s, m, i, dt1, dt2, dt3 ;
- XEvent event;
- char command[1024], Line[512], FileName[10];
- FILE *fp;
-- char* Weather;
-- char* Clouds;
-- char* tmp1;
-- char* tmp2;
-+ char* Weather = NULL;
-+ char* Clouds = NULL;
-+ char* tmp1 = NULL;
-+ char* tmp2 = NULL;
- int intensity=0;
- char* precip;
- char* desc;
-@@ -238,7 +238,7 @@ FILE *fp;
- keepgoing=1;
- {
-
-- do{
-+ if (weatherFound) do{
-
-
- tmp1=mystrsep(&Weather,";");
-@@ -289,7 +289,7 @@ FILE *fp;
- while(keepgoing);
- }
-
-- do{
-+ if (cloudsFound) do{
- tmp1=mystrsep(&Clouds,";");
- if(tmp1)
- {
---
-1.6.3.3
-
diff --git a/x11-plugins/wmfrog/files/02-buffer-overflow-0.2.0.patch b/x11-plugins/wmfrog/files/02-buffer-overflow-0.2.0.patch
deleted file mode 100644
index c4267585836c..000000000000
--- a/x11-plugins/wmfrog/files/02-buffer-overflow-0.2.0.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 5cc2198aebf090b399bd8aaea0e1c8b054bbda58 Mon Sep 17 00:00:00 2001
-From: Jim Ramsay <i.am@jimramsay.com>
-Date: Thu, 6 Aug 2009 12:51:56 -0400
-Subject: [PATCH] Remove buffer overflows
-
-Replaced all 'sprintf' calls with 'snprintf' and fixed all buffers to reasonable
-sizes.
----
- Src/wmFrog.c | 11 +++++------
- 1 files changed, 5 insertions(+), 6 deletions(-)
-
-diff --git a/Src/wmFrog.c b/Src/wmFrog.c
-index af4101a..74e8b56 100644
---- a/Src/wmFrog.c
-+++ b/Src/wmFrog.c
-@@ -66,7 +66,7 @@ char* folder;
- int main(int argc, char *argv[]) {
- int n, s, m, i, dt1, dt2, dt3 ;
- XEvent event;
--char command[1024], Line[512], FileName[10];
-+char command[1024], Line[512], FileName[128];
- FILE *fp;
- char* Weather = NULL;
- char* Clouds = NULL;
-@@ -213,7 +213,7 @@ FILE *fp;
-
- dt2 = 0;
-
-- sprintf(FileName, "%s/%s", folder, StationID);
-+ snprintf(FileName, 128, "%s/%s", folder, StationID);
- fprintf(stderr,"%s\n\n",FileName);
- if ((fp = fopen(FileName, "r")) != NULL){
- fscanf(fp, "Hour:%d", &hour);
-@@ -571,7 +571,7 @@ UpToDate = 0;
- /*
- * Execute Perl script to grab the Latest METAR Report
- */
-- sprintf(command, "/usr/lib/wmfrog/weather.pl %s %s &", StationID, folder);
-+ snprintf(command, 1024, "/usr/lib/wmfrog/weather.pl %s %s &", StationID, folder);
- //printf("Retrieveing data\n");
- system(command);
- ForceDownload = 0;
-@@ -844,12 +844,11 @@ char *GetTempDir(char *suffix)
- {
- uid_t id;
- struct passwd *userEntry;
-- char * userHome;
-+ static char userHome[128];
-
- id=getuid();
- userEntry=getpwuid(id);
-- userHome=userEntry->pw_dir;
-- sprintf(userHome,"%s/%s",userHome,suffix);
-+ snprintf(userHome, 128, "%s/%s", userEntry->pw_dir, suffix);
- return userHome;
- }
-
---
-1.6.3.3
-
diff --git a/x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild b/x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild
deleted file mode 100644
index ec123100e9b1..000000000000
--- a/x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-inherit eutils toolchain-funcs
-
-DESCRIPTION="a weather application, it shows the weather in a graphical way"
-HOMEPAGE="http://wiki.colar.net/wmfrog_dockapp"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE=""
-
-RDEPEND="x11-libs/libXext
- x11-libs/libXpm
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-S=${WORKDIR}/Src
-
-src_prepare() {
- epatch "${FILESDIR}"/*-${PV}.patch
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" INCDIR="" \
- LIBDIR="" SYSTEM="${LDFLAGS}" || die "emake failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc ../{CHANGES,HINTS}
-}