summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-20 20:43:39 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-21 09:13:49 +0100
commit3ae887f91528a5a6ebc5d4914dd714194360a131 (patch)
treefecba39aeeaab4a742064d4785472a94042f87d2 /x11-misc/xidle/xidle-26052015.ebuild
parentx11-misc/xsnap: EAPI bump 5 -> 6 (diff)
downloadgentoo-3ae887f91528a5a6ebc5d4914dd714194360a131.tar.gz
gentoo-3ae887f91528a5a6ebc5d4914dd714194360a131.tar.bz2
gentoo-3ae887f91528a5a6ebc5d4914dd714194360a131.zip
x11-misc/xidle: Bump to 26052015, EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4046
Diffstat (limited to 'x11-misc/xidle/xidle-26052015.ebuild')
-rw-r--r--x11-misc/xidle/xidle-26052015.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/xidle/xidle-26052015.ebuild b/x11-misc/xidle/xidle-26052015.ebuild
new file mode 100644
index 000000000000..86b0c0e124df
--- /dev/null
+++ b/x11-misc/xidle/xidle-26052015.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Monitors inactivity in X and runs the specified program when a timeout occurs"
+HOMEPAGE="http://www.freebsdsoftware.org/x11/xidle.html"
+SRC_URI="http://distcache.freebsd.org/local-distfiles/novel/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-dead.patch" )
+
+src_compile() {
+ local my_compile="$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN}{,.c}
+ $($(tc-getPKG_CONFIG) --libs xscrnsaver) $($(tc-getPKG_CONFIG) --libs x11)"
+ echo ${my_compile} || die
+ eval ${my_compile} || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}
+
+pkg_postinst() {
+ elog "If you don't specify -program argument for xidle, xlock is ran by default."
+ elog "Install x11-misc/xlockmore for xlock if you wish to use default behaviour."
+}