summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-26 11:44:39 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-28 20:10:42 +0100
commita76400e3c9c4646d8f790362e1d2cc726488a450 (patch)
tree22fdf6487b84f1cc4321b0674380b3875f749701 /x11-misc/piedock/piedock-1.6.6-r1.ebuild
parentx11-misc/fbpanel: Version bump to 7.0 (diff)
downloadgentoo-a76400e3c9c4646d8f790362e1d2cc726488a450.tar.gz
gentoo-a76400e3c9c4646d8f790362e1d2cc726488a450.tar.bz2
gentoo-a76400e3c9c4646d8f790362e1d2cc726488a450.zip
x11-misc/piedock: Fix build with gcc6, bug #594478
Gentoo-Bug: https://bugs.gentoo.org/594478 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4085
Diffstat (limited to 'x11-misc/piedock/piedock-1.6.6-r1.ebuild')
-rw-r--r--x11-misc/piedock/piedock-1.6.6-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/piedock/piedock-1.6.6-r1.ebuild b/x11-misc/piedock/piedock-1.6.6-r1.ebuild
new file mode 100644
index 000000000000..8c945ddda0e9
--- /dev/null
+++ b/x11-misc/piedock/piedock-1.6.6-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A little bit like the famous OS X dock but in shape of a pie menu"
+HOMEPAGE="http://markusfisch.de/PieDock"
+SRC_URI="http://markusfisch.de/downloads/${P}.tar.bz2
+ https://github.com/markusfisch/PieDock/commit/a7fda1896f1cc6966ba0fa8912e9b404c1b0be97.patch -> ${P}-gcc6.patch"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk kde"
+
+RDEPEND="
+ media-libs/libpng:0=
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXrender
+ gtk? (
+ dev-libs/atk
+ dev-libs/glib
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ )
+ kde? (
+ kde-frameworks/kdelibs:4
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( res/${PN}rc.sample AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-signals.patch
+ "${DISTDIR}"/${P}-gcc6.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable gtk) \
+ $(use_enable kde) \
+ --bindir="${EPREFIX}"/usr/bin \
+ --enable-xft \
+ --enable-xmu \
+ --enable-xrender
+}