summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-09-30 12:24:46 +0200
committerPacho Ramos <pacho@gentoo.org>2018-09-30 12:24:46 +0200
commit66a47798fa3de7c06628ad07399093ae97dd924e (patch)
tree72771ea352a351cdcb95cd8fe9c976e5f02b2418 /x11-libs
parentsci-libs/netcdf: Update subslot (#654036 by Jouni Kosonen) (diff)
downloadgentoo-66a47798fa3de7c06628ad07399093ae97dd924e.tar.gz
gentoo-66a47798fa3de7c06628ad07399093ae97dd924e.tar.bz2
gentoo-66a47798fa3de7c06628ad07399093ae97dd924e.zip
x11-libs/agg: Fix build with gcc8 (#664078)
Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/agg/agg-2.5-r3.ebuild9
-rw-r--r--x11-libs/agg/files/agg-2.5-gcc8.patch24
2 files changed, 29 insertions, 4 deletions
diff --git a/x11-libs/agg/agg-2.5-r3.ebuild b/x11-libs/agg/agg-2.5-r3.ebuild
index 0925c837a906..b2def3f9fd88 100644
--- a/x11-libs/agg/agg-2.5-r3.ebuild
+++ b/x11-libs/agg/agg-2.5-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools ltprune
+EAPI=7
+inherit autotools
DESCRIPTION="High quality rendering engine library for C++"
HOMEPAGE="http://antigrain.com/"
@@ -32,6 +32,7 @@ PATCHES=(
"${FILESDIR}"/${P}-autotools.patch
"${FILESDIR}"/${P}-sdl-m4.patch
"${FILESDIR}"/${P}-sdl-automagic.patch
+ "${FILESDIR}"/${P}-gcc8.patch
"${FILESDIR}"/${PVR}
)
@@ -56,5 +57,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ find "${D}" -name '*.la' -delete || die
}
diff --git a/x11-libs/agg/files/agg-2.5-gcc8.patch b/x11-libs/agg/files/agg-2.5-gcc8.patch
new file mode 100644
index 000000000000..6214bd62e3ab
--- /dev/null
+++ b/x11-libs/agg/files/agg-2.5-gcc8.patch
@@ -0,0 +1,24 @@
+From ca818d4dcd428c5560fc3c341fbaf427a7485e32 Mon Sep 17 00:00:00 2001
+From: Tom Hughes <tom@compton.nu>
+Date: Sat, 22 Jun 2013 12:34:37 +0100
+Subject: [PATCH 15/15] Ensure first value in the gamma table is always zero
+
+---
+ include/agg_gamma_functions.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/agg_gamma_functions.h b/include/agg_gamma_functions.h
+index beb0c04..b8eda52 100644
+--- a/include/agg_gamma_functions.h
++++ b/include/agg_gamma_functions.h
+@@ -49,6 +49,7 @@ namespace agg
+
+ double operator() (double x) const
+ {
++ if (x == 0.0) return 0.0;
+ return pow(x, m_gamma);
+ }
+
+--
+1.8.1.4
+