summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-18 13:28:29 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-18 14:10:08 -0400
commitd6d0fbc2dc1e0a44919a595a68abc92fa7d0eedb (patch)
tree879c119d698cfa3635407a53affeb64912be2092 /x11-libs/xcb-util-cursor
parentx11-libs/libxshmfence: Version bump to 1.3.1 (diff)
downloadgentoo-d6d0fbc2dc1e0a44919a595a68abc92fa7d0eedb.tar.gz
gentoo-d6d0fbc2dc1e0a44919a595a68abc92fa7d0eedb.tar.bz2
gentoo-d6d0fbc2dc1e0a44919a595a68abc92fa7d0eedb.zip
x11-libs/xcb-util-cursor: Version bump to 0.1.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/xcb-util-cursor')
-rw-r--r--x11-libs/xcb-util-cursor/Manifest1
-rw-r--r--x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-cursor/Manifest b/x11-libs/xcb-util-cursor/Manifest
index ee189ce86170..b5276649a5ad 100644
--- a/x11-libs/xcb-util-cursor/Manifest
+++ b/x11-libs/xcb-util-cursor/Manifest
@@ -1 +1,2 @@
DIST xcb-util-cursor-0.1.3.tar.bz2 295224 BLAKE2B 7a1a89c0f326f4ac0768110c4aa5a7818ddace1f231f6a0dcfacaf8b157a2d6aae53f5278a02cb945822d83eccb8a01ebb14ab98e8828d8f1d506e42f51431ba SHA512 be5eee7b268b18f356d6aae04820a7e1c51397dac9020d876df379e833200255b5194269541c245a9b4ac286edad4cfe44dae8e4fcfd16a4726dd7553c104c21
+DIST xcb-util-cursor-0.1.4.tar.xz 265508 BLAKE2B 8d7eac0116652833e1835e9c7454bc859901e146b06985b3926fd5f7568d92f2249ef6ea17c2202fa247e36bb998ba5b76fa519e92ca5cd51eb778169c88218c SHA512 d27dd59a4d7ded9994dca77774421dd9533e3ee823b880af35d3219bd7340c89fbc61d1d0fa10e2991de2cac9e6395e09497769d7b8728eedc691e76649107b1
diff --git a/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.4.ebuild b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.4.ebuild
new file mode 100644
index 000000000000..3f3659032f51
--- /dev/null
+++ b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb-cursor"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-image-0.3.9-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-0.3.9[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.8-r3:=
+ x11-base/xorg-proto"
+BDEPEND=">=dev-util/gperf-3.0.1"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-cursorpath='~/.cursors:~/.icons:/usr/local/share/cursors/xorg-x11:/usr/local/share/cursors:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/share/cursors/xorg-x11:/usr/share/cursors:/usr/share/pixmaps/xorg-x11:/usr/share/icons:/usr/share/pixmaps'
+)