summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-11-07 12:49:07 +0100
committerJeroen Roovers <jer@gentoo.org>2016-11-07 12:55:30 +0100
commitac2344fe712254028967e187c13290f79cba9de3 (patch)
treefba7622aed9afc9893f9d9beaa7c3e3d84d9a290 /www-plugins/adobe-flash
parentdev-perl/DBD-mysql: Bump to 4.38.10_rc ( Development ) re: bug #599068 (diff)
downloadgentoo-ac2344fe712254028967e187c13290f79cba9de3.tar.gz
gentoo-ac2344fe712254028967e187c13290f79cba9de3.tar.bz2
gentoo-ac2344fe712254028967e187c13290f79cba9de3.zip
www-plugins/adobe-flash: Replace one ugly hack with another.
Package-Manager: portage-2.3.2
Diffstat (limited to 'www-plugins/adobe-flash')
-rw-r--r--www-plugins/adobe-flash/adobe-flash-24.0.0.145.ebuild21
1 files changed, 6 insertions, 15 deletions
diff --git a/www-plugins/adobe-flash/adobe-flash-24.0.0.145.ebuild b/www-plugins/adobe-flash/adobe-flash-24.0.0.145.ebuild
index 805ee9dc4394..98e99fb765db 100644
--- a/www-plugins/adobe-flash/adobe-flash-24.0.0.145.ebuild
+++ b/www-plugins/adobe-flash/adobe-flash-24.0.0.145.ebuild
@@ -61,26 +61,17 @@ src_unpack() {
multilib_parallel_foreach_abi multilib_src_unpack
}
-src_prepare() {
- # XXX: if we find a directory named "lib" we know it should be "lib32"
- for af_dir in $(find "${WORKDIR}" -name lib); do
- mv -v ${af_dir} ${af_dir}32
- done
-
- default
-}
-
multilib_src_install() {
+ local pkglibdir=lib
+ [[ -d usr/lib64 ]] && pkglibdir=lib64
+
if use npapi; then
# PLUGINS_DIR comes from nsplugins.eclass
exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
- doexe usr/$(get_libdir)/flash-plugin/libflashplayer.so
+ doexe usr/${pkglibdir}/flash-plugin/libflashplayer.so
if multilib_is_native_abi; then
if use kde; then
- local pkglibdir=lib
- [[ -d usr/lib64 ]] && pkglibdir=lib64
-
exeinto /usr/$(get_libdir)/kde4
doexe usr/${pkglibdir}/kde4/kcm_adobe_flash_player.so
insinto /usr/share/kde4/services
@@ -108,9 +99,9 @@ multilib_src_install() {
if use ppapi; then
exeinto /usr/$(get_libdir)/chromium-browser/PepperFlash
- doexe usr/$(get_libdir)/flash-plugin/libpepflashplayer.so
+ doexe usr/${pkglibdir}/flash-plugin/libpepflashplayer.so
insinto /usr/$(get_libdir)/chromium-browser/PepperFlash
- doins usr/$(get_libdir)/flash-plugin/manifest.json
+ doins usr/${pkglibdir}/flash-plugin/manifest.json
if multilib_is_native_abi; then
dodir /etc/chromium