summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-29 17:09:01 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-29 21:31:22 +0200
commitad01f72440864bf2b85f392dd363534ecc6811a3 (patch)
treea2398ad07f7b71f3911bc99f73cb17676cce5c13 /www-client
parentapp-arch/dtrx: bump to 8.5.2 (diff)
downloadgentoo-ad01f72440864bf2b85f392dd363534ecc6811a3.tar.gz
gentoo-ad01f72440864bf2b85f392dd363534ecc6811a3.tar.bz2
gentoo-ad01f72440864bf2b85f392dd363534ecc6811a3.zip
www-client/tangram: bump to 3.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/tangram/Manifest1
-rw-r--r--www-client/tangram/tangram-3.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/www-client/tangram/Manifest b/www-client/tangram/Manifest
index 0bac93610a6a..fbece4354f79 100644
--- a/www-client/tangram/Manifest
+++ b/www-client/tangram/Manifest
@@ -1 +1,2 @@
DIST tangram-2.0.tar.xz 991180 BLAKE2B 1f51b8218a2d7bec9581335319448548765c26f6057ce2be0c5862324fe6659637040f8c878829505550c9c49707987c3f12b707b549f087805bb1adae12ae3d SHA512 e851153f1621e7e14dd4c5445de108126adbb0f56396331b8c2d3354ba49c1ea77b5053e5557d02f1ba817d04c2553f68ab18a9afbc4842a258e0bf9e6a798d6
+DIST tangram-3.0.tar.xz 1379104 BLAKE2B 8a067daf3df328d98af70e66c270ea4e03a5dc6e0e1693d05439feac8cb34bc0816890164fa83f37a1de409a926d8556a192f980586cb71f15bcecb134b89526 SHA512 68914f9f0c08ab272635ae71f796df1e4c66c919a7718e90714978dc16e434681aa8fb475d33bfaaeba31cdb690975457fa9e97f6d866c323e8585149cee7c7b
diff --git a/www-client/tangram/tangram-3.0.ebuild b/www-client/tangram/tangram-3.0.ebuild
new file mode 100644
index 000000000000..bb7361b4cb58
--- /dev/null
+++ b/www-client/tangram/tangram-3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson xdg
+
+DESCRIPTION="Web browser designed to organize and run Web applications"
+HOMEPAGE="https://apps.gnome.org/app/re.sonny.Tangram/
+ https://github.com/sonnyp/Tangram/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sonnyp/${PN^}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/gjs-1.76.0
+ gui-libs/gtk:4
+ gui-libs/libadwaita:1
+ net-libs/webkit-gtk:6
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/blueprint-compiler
+ dev-util/desktop-file-utils
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0-dont-validate-appstream.patch )
+
+DOCS=( README.md TODO.md )
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}