summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-07-28 19:34:19 +1000
committerMatt Jolly <kangie@gentoo.org>2024-07-28 19:35:05 +1000
commit2b96b04ef3d7b876ccf29de8ee1738f49112c95f (patch)
treed5a37119f472930619dc5d468db2253debb07477 /www-client
parenteclass/tests: Include tests in version-funcs.sh itself (diff)
downloadgentoo-2b96b04ef3d7b876ccf29de8ee1738f49112c95f.tar.gz
gentoo-2b96b04ef3d7b876ccf29de8ee1738f49112c95f.tar.bz2
gentoo-2b96b04ef3d7b876ccf29de8ee1738f49112c95f.zip
www-client/chromium: forcibly disable 'updater' target for 127
Closes: https://bugs.gentoo.org/936673 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-127.0.6533.72.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-127.0.6533.72.ebuild b/www-client/chromium/chromium-127.0.6533.72.ebuild
index ac25cba49b1b..0861db4237d8 100644
--- a/www-client/chromium/chromium-127.0.6533.72.ebuild
+++ b/www-client/chromium/chromium-127.0.6533.72.ebuild
@@ -1118,6 +1118,11 @@ chromium_configure() {
myconf_gn+=" arm_control_flow_integrity=\"none\""
fi
+ # 936673: Updater (which we don't use) depends on libsystemd
+ # This _should_ always be disabled if we're not building a
+ # "Chrome" branded browser, but obviously this is not always sufficient.
+ myconf_gn+=" enable_updater=false"
+
# Enable official builds
myconf_gn+=" is_official_build=$(usex official true false)"
myconf_gn+=" use_thin_lto=$(usex lto true false)"