summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-11-08 18:23:43 +0100
committerSam James <sam@gentoo.org>2024-12-01 11:52:12 +0000
commitd75da48b8ecb96b29157f6c74744ad4fc67e8891 (patch)
tree481ca3ee96846442c3960b4ef63d0f106f60d45f /www-apps
parentwww-apps/icingaweb2: [QA] BannedEapiCommand (diff)
downloadgentoo-d75da48b8ecb96b29157f6c74744ad4fc67e8891.tar.gz
gentoo-d75da48b8ecb96b29157f6c74744ad4fc67e8891.tar.bz2
gentoo-d75da48b8ecb96b29157f6c74744ad4fc67e8891.zip
www-apps/icingaweb2: drop 2.12.1 2.11.4-r1
Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.11.4-r1.ebuild80
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.12.1.ebuild80
3 files changed, 0 insertions, 161 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 421f828ec4af..9ef65e743afc 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1 @@
-DIST icingaweb2-2.11.4.tar.gz 11381515 BLAKE2B e524d04fd027377685826e1e3ff4a73efb040f8736d35fa496cf190a69dc2e6fedd82f678d5994d66a450efaff77764fd6a9504823ba17897506ff3d923566d8 SHA512 3012e75c35f3070a5dfcb356ed499f247651c99b7f39faf1917ade4568f5ba15a2820ff63cab2583748cdb7d158f86b7b87bf8f4c934d3bd6526929dd57e1eae
DIST icingaweb2-2.12.1.tar.gz 6353911 BLAKE2B c1f52444c2ccc1eeafce89603564f21269607bc183a3189b80d93ccba5d621bf8c8bd79c75e5c9aaeb6672870923f99c98c7ebc469147125a803d16b00f9426d SHA512 71e6ad8f947ee47ff0bd3924920584c558fbd8e371f76adb83cc08e95442e792009af79280c484afe478cf1a176cf2812c6be661d838f61f044abdc106ca0999
diff --git a/www-apps/icingaweb2/icingaweb2-2.11.4-r1.ebuild b/www-apps/icingaweb2/icingaweb2-2.11.4-r1.ebuild
deleted file mode 100644
index 8df6a13afcc7..000000000000
--- a/www-apps/icingaweb2/icingaweb2-2.11.4-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit depend.apache
-
-DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
-HOMEPAGE="http://www.icinga.org/"
-
-if [[ ${PV} == *9999 ]];then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
-REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
-
-DEPEND=">=net-analyzer/icinga2-2.1.1
- dev-php/pecl-imagick
- pdf? ( media-gfx/imagemagick[png] )
- apache2-server? ( >=www-servers/apache-2.4.0 )
- nginx? ( >=www-servers/nginx-1.7.0:* )
- || (
- dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:8.1[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- )
- >=dev-libs/icinga-php-library-0.8.1
- >=dev-libs/icinga-php-thirdparty-0.11.0
- acct-group/icingacmd
- acct-group/icingaweb2"
-RDEPEND="${DEPEND}"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
-
- use nginx && usermod -a -G icingacmd,icingaweb2 nginx
- use apache2 && usermod -a -G icingacmd,icingaweb2 apache
-}
-
-pkg_config() {
- if [[ -d /etc/icingaweb2 ]] ; then
- einfo "Updating existing installation ..."
- else
- einfo "Running first time setup ..."
- einfo "Creating configuration directory ..."
- /usr/share/${PN}/bin/icingacli setup config directory
- einfo "Creating authentication token for web setup ..."
- /usr/share/${PN}/bin/icingacli setup token create
- if use apache2 ; then
- einfo "The following might be useful for your Apache2 configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
- fi
- if use nginx ; then
- einfo "The following might be useful for your NGinx configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
- fi
- fi
- einfo "All done."
-}
-
-src_install() {
- insinto "/usr/share/${PN}"
- doins -r "${S}"/*
- fperms -R a+rX "/usr/share/${PN}/public/"
- fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
- fowners root:icingaweb2 "/usr/share/${PN}/bin/icingacli"
-}
-
-pkg_postinst() {
- einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
-}
diff --git a/www-apps/icingaweb2/icingaweb2-2.12.1.ebuild b/www-apps/icingaweb2/icingaweb2-2.12.1.ebuild
deleted file mode 100644
index bbe044604cc1..000000000000
--- a/www-apps/icingaweb2/icingaweb2-2.12.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit depend.apache
-
-DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
-HOMEPAGE="https://icinga.com/"
-
-if [[ ${PV} == *9999 ]];then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
-REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
-
-DEPEND=">=net-analyzer/icinga2-2.1.1
- dev-php/pecl-imagick
- pdf? ( media-gfx/imagemagick[png] )
- apache2-server? ( >=www-servers/apache-2.4.0 )
- nginx? ( >=www-servers/nginx-1.7.0:* )
- || (
- dev-lang/php:8.1[apache2?,cli,curl,fileinfo,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:8.2[apache2?,cli,curl,fileinfo,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- )
- >=dev-libs/icinga-php-library-0.13.0
- >=dev-libs/icinga-php-thirdparty-0.12.0
- acct-group/icingacmd
- acct-group/icingaweb2"
-RDEPEND="${DEPEND}"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
-
- use nginx && usermod -a -G icingacmd,icingaweb2 nginx
- use apache2 && usermod -a -G icingacmd,icingaweb2 apache
-}
-
-pkg_config() {
- if [[ -d /etc/icingaweb2 ]] ; then
- einfo "Updating existing installation ..."
- else
- einfo "Running first time setup ..."
- einfo "Creating configuration directory ..."
- /usr/share/${PN}/bin/icingacli setup config directory
- einfo "Creating authentication token for web setup ..."
- /usr/share/${PN}/bin/icingacli setup token create
- if use apache2 ; then
- einfo "The following might be useful for your Apache2 configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
- fi
- if use nginx ; then
- einfo "The following might be useful for your NGinx configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
- fi
- fi
- einfo "All done."
-}
-
-src_install() {
- insinto "/usr/share/${PN}"
- doins -r "${S}"/*
- fperms -R a+rX "/usr/share/${PN}/public/"
- fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
- fowners root:icingaweb2 "/usr/share/${PN}/bin/icingacli"
-}
-
-pkg_postinst() {
- einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
-}