summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-09-22 15:01:39 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-09-26 19:52:55 +0300
commit39fa621f1533527cf346e2a706ea061d5a224c10 (patch)
tree202aabcd8e6c0d05b4cc10dbba94d2759b6881fd /www-apps
parentsci-electronics/nvc: remove unused verilog option (diff)
downloadgentoo-39fa621f1533527cf346e2a706ea061d5a224c10.tar.gz
gentoo-39fa621f1533527cf346e2a706ea061d5a224c10.tar.bz2
gentoo-39fa621f1533527cf346e2a706ea061d5a224c10.zip
www-apps/rutorrent: add 4.3.7
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/38724 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-4.3.7.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 3d21e918561e..3650af1a82f8 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1 +1,2 @@
DIST rutorrent-4.3.6.tar.gz 2377710 BLAKE2B f3bab570ebf7e577d0587ed4fef7e1cb5c40e256f9b4bc6f8cdb603ef516ad6a666ea52314f4c3f6e0ab4991e6027e12e5d6c76320b58747eaf37d0e52e6d6a8 SHA512 bfed8e799b0261f974678f24056070339b443cd24fa53db14585d141e31237c391d51a0bb4675c39930a3288d6cd758524dc77711f7e46e3af0d1df4bbc97917
+DIST rutorrent-4.3.7.tar.gz 2377776 BLAKE2B caa90838d4ac390cdeeafa46dcccf2b3ad955913f0e1b9e00f89912440ab2a6470cc4a73724f8a2b9700dd879c154099a88355bf769dffd5285a7926b36e46a5 SHA512 79d28a20c544dd37303c654d33c3eea88e3aac3a449c8be30c725de60f7253ac10d0f70f3e47528d8734b10cf1b69325da58915d9cad0c29c22c2c70a12a6982
diff --git a/www-apps/rutorrent/rutorrent-4.3.7.ebuild b/www-apps/rutorrent/rutorrent-4.3.7.ebuild
new file mode 100644
index 000000000000..97453fadf5c8
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.3.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}