summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-11-02 18:21:10 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2022-11-02 22:01:35 +0100
commit46f264e16ced5f5d2a86434f59cacf8b3ac6143d (patch)
treedfcd9f4756faebbb2906df9dccee5feead42e1b9 /www-apps/nextcloud
parentsys-auth/AusweisApp2: add 1.24.4 (diff)
downloadgentoo-46f264e16ced5f5d2a86434f59cacf8b3ac6143d.tar.gz
gentoo-46f264e16ced5f5d2a86434f59cacf8b3ac6143d.tar.bz2
gentoo-46f264e16ced5f5d2a86434f59cacf8b3ac6143d.zip
www-apps/nextcloud: add 23.0.10, 24.0.6, 25.0.0
Closes: https://bugs.gentoo.org/877859 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/nextcloud')
-rw-r--r--www-apps/nextcloud/Manifest3
-rw-r--r--www-apps/nextcloud/nextcloud-23.0.10.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-24.0.6.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-25.0.0.ebuild43
4 files changed, 132 insertions, 0 deletions
diff --git a/www-apps/nextcloud/Manifest b/www-apps/nextcloud/Manifest
index fb63dcbf340e..797e2398396f 100644
--- a/www-apps/nextcloud/Manifest
+++ b/www-apps/nextcloud/Manifest
@@ -1,3 +1,6 @@
+DIST nextcloud-23.0.10.tar.bz2 141026523 BLAKE2B 52e2962c1bd8075a64b10e792b18f7e18688c4a1227ef71cfbc85fe743a924ead8a78c3ed95396c37c3c85fa9a848eb3017d0c818294bbad35d679cc0844b0a5 SHA512 be4cfcd728db5c492da68c5aad29caab926673ad623ef3050c8f193d58164aaea04679f63e01eaf59652f0f6d8237c64fb38e66a08fd35e0e43b10f2b67b4d64
DIST nextcloud-23.0.8.tar.bz2 140679380 BLAKE2B 0d5c22f28bd3fb8b27099a3b92a34042b347d444dadca6be90022f1ca0fc8d1d6f17fa0e87313ca0f9e003e066cad245dcade62def8b6af16b5c4241ff9e1e03 SHA512 e4bd8000eb26e375a473a6dc877ad43ce09409daa4e24b7087cf5c0c32dcb7063aa3e962d59e8332c1c7d103e1b7381d0c309081d86f9f6e93334f0e806b74b0
DIST nextcloud-23.0.9.tar.bz2 140677417 BLAKE2B 3a3d63ab8a0f8b099f78ef52b03de3b15838fdbb0663cc858e60ba2dad9c9fbcb8afbbe7acf00b3816b1a39f1aeed7aabc412d7a2fa96caf65b972ad57d0adc2 SHA512 0621c3a59bee7c5adf9a70053c0e002ae94647fecf0fbc96b38f8b3090dd16f5045ec80ac8996d3a15b5e976ef0e1fed37a428a3f305eb7cf14b01cf94d9d3b3
DIST nextcloud-24.0.5.tar.bz2 123536042 BLAKE2B 8a1117ab5d802a37ee82ddbe4f0ec7aeb2ada2816a60cf7727dac6f48325b3b46eea8b90d6aed90d184492ba62be06f75ac587ec1c86cce8f8569d20d6f65d0f SHA512 2673853ba97bb868b318b9bb5025bb44dfdb6c82a9d518bb9c5ee642b781ce39f05fd1b31517946e8cace329cd0ab613341005a39b84afe86cd157a8404d4fcd
+DIST nextcloud-24.0.6.tar.bz2 123902888 BLAKE2B 145d3b3c9527ac950f12a88cd02085c566d3d8e224d7ec099bcb9e519c3d2854954b23ea27ee62ff2ae3032d3788bb494b38ef1fc26bc9cf3991e0fd864120d0 SHA512 15c45f8ae4ee9e03c35f8aef6549b9fe92984dac4345406bbc95eec9099912f10a9ad8a7b73c001cc96294d2d136259acc4003d6610c47254ca5cac9d701343d
+DIST nextcloud-25.0.0.tar.bz2 144109342 BLAKE2B a339f5bf01255cccdbb9941d360e091a34149e6d3a365497344911c8f156cd7b272ed657fe48720054c448c3e52fafec37dbe0cd69be42f424479d35dd90e547 SHA512 6f7a7a4e7b613df7b246bf9a582a15598d40a96023bdde1d8e3fff1b5888588d9c957f58ea813470696edc7c1ad5e8d1721d5eaa3d9c91549ca8acc411a8211e
diff --git a/www-apps/nextcloud/nextcloud-23.0.10.ebuild b/www-apps/nextcloud/nextcloud-23.0.10.ebuild
new file mode 100644
index 000000000000..ae0486c3b736
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-23.0.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.1[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-24.0.6.ebuild b/www-apps/nextcloud/nextcloud-24.0.6.ebuild
new file mode 100644
index 000000000000..e35dd132e50a
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-24.0.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-25.0.0.ebuild b/www-apps/nextcloud/nextcloud-25.0.0.ebuild
new file mode 100644
index 000000000000..e35dd132e50a
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-25.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8.2[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}