summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-25 11:11:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-25 11:11:02 -0500
commita88a5b1785824350199e1c17e4254a042b7339b0 (patch)
treefae4288a82b432a42497a3f030be685fbfa50a2d /www-apps/icingaweb2/icingaweb2-9999.ebuild
parentnet-analyzer/icinga2: stable amd64 and x86 (diff)
downloadgentoo-a88a5b1785824350199e1c17e4254a042b7339b0.tar.gz
gentoo-a88a5b1785824350199e1c17e4254a042b7339b0.tar.bz2
gentoo-a88a5b1785824350199e1c17e4254a042b7339b0.zip
www-apps/icingaweb2: fixing fpm usage for nginx
Package-Manager: portage-2.2.28
Diffstat (limited to 'www-apps/icingaweb2/icingaweb2-9999.ebuild')
-rw-r--r--www-apps/icingaweb2/icingaweb2-9999.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/www-apps/icingaweb2/icingaweb2-9999.ebuild b/www-apps/icingaweb2/icingaweb2-9999.ebuild
index 320a8196ebca..8caad1657ff4 100644
--- a/www-apps/icingaweb2/icingaweb2-9999.ebuild
+++ b/www-apps/icingaweb2/icingaweb2-9999.ebuild
@@ -14,13 +14,25 @@ EGIT_BRANCH="master"
LICENSE="GPL-2"
SLOT="0"
IUSE="apache2 ldap mysql nginx postgres"
+REQUIRED_USE="^^ ( apache2 nginx )"
KEYWORDS=""
DEPEND=">=net-analyzer/icinga2-2.1.1
- dev-lang/php:*[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
dev-php/pecl-imagick
- apache2? ( >=www-servers/apache-2.4.0 )
- nginx? ( >=www-servers/nginx-1.7.0:* )"
+ apache2? (
+ >=www-servers/apache-2.4.0
+ || (
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )
+ nginx? (
+ >=www-servers/nginx-1.7.0:*
+ || (
+ dev-lang/php:5.6[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )"
RDEPEND="${DEPEND}"
want_apache2