summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-08-23 22:22:57 -0400
committerRick Farina <zerochaos@gentoo.org>2023-08-23 22:22:57 -0400
commitcf21ccc131ba8e1d69c49071aa2b34b6f3550ae2 (patch)
treeec5319d2e8d0a68951c37a5bad2cdb1049080722 /sys-process
parentapp-crypt/hashcat: restrict test (diff)
downloadgentoo-cf21ccc131ba8e1d69c49071aa2b34b6f3550ae2.tar.gz
gentoo-cf21ccc131ba8e1d69c49071aa2b34b6f3550ae2.tar.bz2
gentoo-cf21ccc131ba8e1d69c49071aa2b34b6f3550ae2.zip
sys-process/usbtop: add 1.0_p20220419
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/usbtop/Manifest1
-rw-r--r--sys-process/usbtop/usbtop-1.0_p20220419.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/usbtop/Manifest b/sys-process/usbtop/Manifest
index 3c2cb4f113e8..9ae70b304008 100644
--- a/sys-process/usbtop/Manifest
+++ b/sys-process/usbtop/Manifest
@@ -1 +1,2 @@
DIST usbtop-1.0.tar.gz 626770 BLAKE2B 4f14e1e8d926ce7f6ffd1a276871d7d9072979d844a55e477c402bcac343a3cc14faebbfd3886b386a48b01399bcb748fb843453a0eee48b8e09578841eab356 SHA512 bc2003c1085fae238d99347bbf3caa1da7e44aa8f5b07abbde3f96b4124b301bbbc896f7b5e341665db1cdba44a59752884e3b9fe3a6104ef804aa94c510a5c0
+DIST usbtop-1.0_p20220419.tar.gz 627690 BLAKE2B 6ba2e5895674383ae4e83abd6907c53e33515bca2cbb1d67063ba1a7429446a67a6b94b3008e830ffee1d620669789e7ececfb5961b2946aac1353599c927e3e SHA512 94a890b94b37b0c7e818be7e7ada4b51e19d51bf7ca7e4b66632532698a04ff1bb05c51c5cb27740b036a98d193024f15249feed4f4044029b737d0609fbb011
diff --git a/sys-process/usbtop/usbtop-1.0_p20220419.ebuild b/sys-process/usbtop/usbtop-1.0_p20220419.ebuild
new file mode 100644
index 000000000000..9446d6cf7767
--- /dev/null
+++ b/sys-process/usbtop/usbtop-1.0_p20220419.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake linux-info
+
+DESCRIPTION="utility that shows an estimated instantaneous bandwidth on USB buses and devices"
+HOMEPAGE="https://github.com/aguinet/usbtop"
+#SRC_URI="https://github.com/aguinet/usbtop/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+COMMIT="b9a26bd22b91b84bd72906c6501e61df7b13f3d6"
+SRC_URI="https://github.com/aguinet/usbtop/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="net-libs/libpcap[usb]"
+DEPEND="${RDEPEND}
+ dev-libs/boost:="
+
+#S="${WORKDIR}/${PN}-release-${PV}"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ CONFIG_CHECK="~USB_MON"
+ check_extra_config
+ fi
+}