summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/ftop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/ftop')
-rw-r--r--sys-process/ftop/Manifest1
-rw-r--r--sys-process/ftop/files/ftop-1.0-overflow.patch14
-rw-r--r--sys-process/ftop/files/ftop-1.0-tinfo.patch10
-rw-r--r--sys-process/ftop/ftop-1.0.ebuild24
-rw-r--r--sys-process/ftop/metadata.xml7
5 files changed, 56 insertions, 0 deletions
diff --git a/sys-process/ftop/Manifest b/sys-process/ftop/Manifest
new file mode 100644
index 000000000000..c17102e4d5fd
--- /dev/null
+++ b/sys-process/ftop/Manifest
@@ -0,0 +1 @@
+DIST ftop-1.0.tar.bz2 143122 SHA256 3a705f4f291384344cd32c3dd5f5f6a7cd7cea7624c83cb7e923966dbcd47f82 SHA512 f572a52481db7d52a1e384500f5ec57eec36fefab95c7237197d69650e6522dd5ddd4c4425a08ffe853ba730519b90de522186aad5d8bd94cece6e66db5e634a WHIRLPOOL 091fd2e25770f77423fbd137d7a4f5b2989d9ac7478b360d7e7d1a22649dcd68b922882d30159e6e136309f92b156f07fb4c9ac886e7c569d17b3084938c89a7
diff --git a/sys-process/ftop/files/ftop-1.0-overflow.patch b/sys-process/ftop/files/ftop-1.0-overflow.patch
new file mode 100644
index 000000000000..f6503fcdbc19
--- /dev/null
+++ b/sys-process/ftop/files/ftop-1.0-overflow.patch
@@ -0,0 +1,14 @@
+Set tmp_buf and rate_buf to something ridiculously high to fix a buffer
+overflow when COLUMNS is large. - JeR
+
+--- a/src/ftop.c 2009-02-16 07:00:00.000000000 +0100
++++ b/src/ftop.c 2013-09-06 14:42:41.788852952 +0200
+@@ -736,7 +736,7 @@
+ {
+ size_t i, j, bytes, bar_total;
+ char more_procs_ch, more_files_ch, expanded_ch;
+- char tmp_buf[80], rate_buf[80];
++ char tmp_buf[2048], rate_buf[2048];
+ char *tmp_str;
+ snapshot *s, *s_prev;
+ file_info *tmp_file;
diff --git a/sys-process/ftop/files/ftop-1.0-tinfo.patch b/sys-process/ftop/files/ftop-1.0-tinfo.patch
new file mode 100644
index 000000000000..cdbc30efa48e
--- /dev/null
+++ b/sys-process/ftop/files/ftop-1.0-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,6 +15,7 @@
+
+ # Checks for libraries.
+ AC_CHECK_LIB([curses], [initscr])
++AC_SEARCH_LIBS(stdscr,tinfo)
+
+ # Checks for header files.
+ AC_HEADER_STDC
diff --git a/sys-process/ftop/ftop-1.0.ebuild b/sys-process/ftop/ftop-1.0.ebuild
new file mode 100644
index 000000000000..979f38c546e0
--- /dev/null
+++ b/sys-process/ftop/ftop-1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=frob
+inherit autotools-utils
+
+DESCRIPTION="Monitor open files and filesystems"
+HOMEPAGE="https://code.google.com/p/ftop/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-overflow.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
diff --git a/sys-process/ftop/metadata.xml b/sys-process/ftop/metadata.xml
new file mode 100644
index 000000000000..4a00a64b40ae
--- /dev/null
+++ b/sys-process/ftop/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>