summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-09-08 18:53:50 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-09-08 18:53:50 +0300
commit3b0b3a7aa120352be09cb3afe6b16b27b22eb624 (patch)
treeee9931dc90ccd9b8ba969dcea17c4d66f2093e50 /sys-process/evisum/evisum-0.2.6.ebuild
parentwww-apache/mod_diagnostics: Fix LICENSE. (diff)
downloadgentoo-3b0b3a7aa120352be09cb3afe6b16b27b22eb624.tar.gz
gentoo-3b0b3a7aa120352be09cb3afe6b16b27b22eb624.tar.bz2
gentoo-3b0b3a7aa120352be09cb3afe6b16b27b22eb624.zip
sys-process/evisum: bump to 0.2.6
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-process/evisum/evisum-0.2.6.ebuild')
-rw-r--r--sys-process/evisum/evisum-0.2.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-process/evisum/evisum-0.2.6.ebuild b/sys-process/evisum/evisum-0.2.6.ebuild
new file mode 100644
index 000000000000..9ea74684dde2
--- /dev/null
+++ b/sys-process/evisum/evisum-0.2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="System and process monitor written with EFL"
+HOMEPAGE="https://www.enlightenment.org/"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/efl"
+RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.2.2-respect-cflags-ldflags.patch" )
+
+src_install() {
+ emake PREFIX="${D}"/usr install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}