summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-04 20:36:53 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-04 20:37:09 -0400
commit9188802088bd9616e71d23dce350f5a278b6f686 (patch)
tree14857191f462f42c0a0bd26ca3f8100191736ee0 /sys-libs/musl/musl-9999.ebuild
parentdev-perl/Test-Pod-Coverage: Remove old (diff)
downloadgentoo-9188802088bd9616e71d23dce350f5a278b6f686.tar.gz
gentoo-9188802088bd9616e71d23dce350f5a278b6f686.tar.bz2
gentoo-9188802088bd9616e71d23dce350f5a278b6f686.zip
sys-libs/musl: iconv, getent and getconf
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-libs/musl/musl-9999.ebuild')
-rw-r--r--sys-libs/musl/musl-9999.ebuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index 85bdc9b32d9b..bf1ebe9fc035 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -2,12 +2,23 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils flag-o-matic multilib toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.musl-libc.org/musl"
inherit git-r3
+ SRC_URI="
+ http://dev.gentoo.org/~blueness/musl-misc/getconf.c
+ http://dev.gentoo.org/~blueness/musl-misc/getent.c
+ http://dev.gentoo.org/~blueness/musl-misc/iconv.c"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz
+ http://dev.gentoo.org/~blueness/musl-misc/getconf.c
+ http://dev.gentoo.org/~blueness/musl-misc/getent.c
+ http://dev.gentoo.org/~blueness/musl-misc/iconv.c"
+ KEYWORDS="-* ~amd64 ~arm ~mips ~ppc ~x86"
fi
export CBUILD=${CBUILD:-${CHOST}}
@@ -20,18 +31,10 @@ fi
DESCRIPTION="Light, fast and simple C library focused on standards-conformance and safety"
HOMEPAGE="http://www.musl-libc.org/"
-if [[ ${PV} != "9999" ]] ; then
- PATCH_VER=""
- SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
- KEYWORDS="-* ~amd64 ~arm ~mips ~ppc ~x86"
-fi
-
LICENSE="MIT LGPL-2 GPL-2"
SLOT="0"
IUSE="crosscompile_opts_headers-only"
-RDEPEND="!sys-apps/getent"
-
QA_SONAME="/usr/lib/libc.so"
QA_DT_NEEDED="/usr/lib/libc.so"
@@ -63,10 +66,6 @@ pkg_setup() {
fi
}
-src_prepare() {
- epatch_user
-}
-
src_configure() {
tc-getCC ${CTARGET}
just_headers && export CC=true
@@ -85,6 +84,9 @@ src_compile() {
just_headers && return 0
emake
+ $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getconf.c -o "${T}"/getconf
+ $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getent.c -o "${T}"/getent
+ $(tc-getCC) ${CFLAGS} "${DISTDIR}"/iconv.c -o "${T}"/iconv
}
src_install() {
@@ -114,7 +116,9 @@ src_install() {
into /
dosbin "${T}"/ldconfig
into /usr
- dobin "${FILESDIR}"/getent
+ dosbin "${T}"/getconf
+ dosbin "${T}"/getent
+ dosbin "${T}"/iconv
echo 'LDPATH="include ld.so.conf.d/*.conf"' > "${T}"/00musl || die
doenvd "${T}"/00musl || die
fi