summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-02-05 10:51:46 +0000
committerJames Le Cuirot <chewi@gentoo.org>2023-02-05 19:07:51 +0000
commit24698e9d84c8effa7848893aed7e6a9aff569a1f (patch)
tree4c45a9eae709af4e6ac0b2d367fd13a2c76f7248 /sys-libs/musl/musl-9999.ebuild
parentdev-util/difftastic: add 0.43.1 (diff)
downloadgentoo-24698e9d84c8effa7848893aed7e6a9aff569a1f.tar.gz
gentoo-24698e9d84c8effa7848893aed7e6a9aff569a1f.tar.bz2
gentoo-24698e9d84c8effa7848893aed7e6a9aff569a1f.zip
sys-libs/musl: Create /etc/ld.so.conf.d directory like glibc does
Given that musl has long added an `include` directive for this directory to ld.so.conf, we believe not creating the directory was an accidental omission. gcc-config has special code to handle the case where it doesn't exist, but eselect modules like blas do not, and subsequently break. I have tested this, and both gcc-config and eselect-blas now behave as expected. There is no migration to do. The tools simply start using the directory once it is available. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'sys-libs/musl/musl-9999.ebuild')
-rw-r--r--sys-libs/musl/musl-9999.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index 231c91cb5ce1..9cd55f813a6c 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -191,6 +191,14 @@ src_install() {
fi
}
+pkg_preinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
+ # prepare /etc/ld.so.conf.d/ for files
+ mkdir -p "${EROOT}"/etc/ld.so.conf.d
+}
+
pkg_postinst() {
is_crosscompile && return 0