summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2022-10-25 14:43:59 +0200
committerSam James <sam@gentoo.org>2022-10-30 09:40:40 +0000
commitf1d0273dc3070fd511e8f65017ea87481934d0b2 (patch)
tree3be5c2d9d353711126d2c9ba6418bff77a4ccdcd /sys-libs/libseccomp
parentmedia-gfx/openvdb: drop 7.0.0-r4, 7.1.0-r5, 8.0.1-r4, 8.1.0, 8.2.0-r3 (diff)
downloadgentoo-f1d0273dc3070fd511e8f65017ea87481934d0b2.tar.gz
gentoo-f1d0273dc3070fd511e8f65017ea87481934d0b2.tar.bz2
gentoo-f1d0273dc3070fd511e8f65017ea87481934d0b2.zip
sys-libs/libseccomp: Rebase libseccomp-python-shared.patch
The libseccomp-python-shared.patch that makes python module depend on libseccomp.so instead of linking it statically in does no longer apply cleanly. Rebase it. Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27943 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/libseccomp')
-rw-r--r--sys-libs/libseccomp/files/libseccomp-2.6.0-python-shared.patch25
-rw-r--r--sys-libs/libseccomp/libseccomp-9999.ebuild2
2 files changed, 26 insertions, 1 deletions
diff --git a/sys-libs/libseccomp/files/libseccomp-2.6.0-python-shared.patch b/sys-libs/libseccomp/files/libseccomp-2.6.0-python-shared.patch
new file mode 100644
index 000000000000..34b12db22112
--- /dev/null
+++ b/sys-libs/libseccomp/files/libseccomp-2.6.0-python-shared.patch
@@ -0,0 +1,25 @@
+From 594fecb16833c693ac0cff8f857aec0edd097077 Mon Sep 17 00:00:00 2001
+Message-Id: <594fecb16833c693ac0cff8f857aec0edd097077.1666701554.git.mprivozn@redhat.com>
+From: Michal Privoznik <mprivozn@redhat.com>
+Date: Tue, 25 Oct 2022 14:39:07 +0200
+Subject: [PATCH] Link python module against shared library
+
+---
+ src/python/setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/python/setup.py b/src/python/setup.py
+index 46f9a73..85deb03 100755
+--- a/src/python/setup.py
++++ b/src/python/setup.py
+@@ -40,6 +40,6 @@ setup(
+ ext_modules = cythonize([
+ Extension("seccomp", ["seccomp.pyx"],
+ # unable to handle libtool libraries directly
+- extra_objects=["../.libs/libseccomp.a"]),
++ extra_objects=["../.libs/libseccomp.so"]),
+ ])
+ )
+--
+2.37.4
+
diff --git a/sys-libs/libseccomp/libseccomp-9999.ebuild b/sys-libs/libseccomp/libseccomp-9999.ebuild
index fed0b3c8f425..e97b661f1bb0 100644
--- a/sys-libs/libseccomp/libseccomp-9999.ebuild
+++ b/sys-libs/libseccomp/libseccomp-9999.ebuild
@@ -37,7 +37,7 @@ BDEPEND="${DEPEND}
python? ( dev-python/cython[${PYTHON_USEDEP}] )"
PATCHES=(
- "${FILESDIR}"/libseccomp-python-shared.patch
+ "${FILESDIR}"/libseccomp-2.6.0-python-shared.patch
"${FILESDIR}"/libseccomp-2.5.3-skip-valgrind.patch
)