summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/libosinfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/libosinfo')
-rw-r--r--sys-libs/libosinfo/Manifest2
-rw-r--r--sys-libs/libosinfo/libosinfo-0.2.11.ebuild52
-rw-r--r--sys-libs/libosinfo/libosinfo-0.2.12.ebuild51
-rw-r--r--sys-libs/libosinfo/metadata.xml5
4 files changed, 110 insertions, 0 deletions
diff --git a/sys-libs/libosinfo/Manifest b/sys-libs/libosinfo/Manifest
new file mode 100644
index 000000000000..64ab92916bd7
--- /dev/null
+++ b/sys-libs/libosinfo/Manifest
@@ -0,0 +1,2 @@
+DIST libosinfo-0.2.11.tar.gz 1304566 SHA256 bb6ba136756b26045ba3ed9b3c1b0920a639dd80b007769a1df356d8e2fe0921 SHA512 a459c6e0e396786b7093685a9a4fe871c12854b1c7c7fb6f0384659fa66be255f3e0c83f0633ecdb42fbb88e18b5f804637fdd145a596bfbc5b6cd41ce08bada WHIRLPOOL 26601de224e58e99f769f8dfaba44a26f31ec7476537b615d46aa61d2b8431362498f7f87ac0bcacd8a1a1044a8a17d2b89e24033abdc90f78a02467c21a800e
+DIST libosinfo-0.2.12.tar.gz 1953453 SHA256 fa00ea8ddbca06c0dcc31e8938ac55cb71e71c6e2449687cd2c9e003a9478fed SHA512 ec09a65a9cfb5e3f2ffe2a7d85b9f51938f1633469338826ab3380f22788d40732b39e0f96005eb6b800d04ac76da09a89918085f840439b5bdde759692c6b9d WHIRLPOOL bddfef060d7a5f794c6f5e7b11798ca8cac5b55812361a8c2d66acd283394a5a0327ba5559cae294a9e49fa9eaca7dc426a92b6a9b68e8314ddc586623ddad6c
diff --git a/sys-libs/libosinfo/libosinfo-0.2.11.ebuild b/sys-libs/libosinfo/libosinfo-0.2.11.ebuild
new file mode 100644
index 000000000000..9a742ee9dba2
--- /dev/null
+++ b/sys-libs/libosinfo/libosinfo-0.2.11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 udev vala
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="http://libosinfo.org/"
+SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+IUSE="+introspection +vala test"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+RDEPEND="
+ >=dev-libs/glib-2:2
+ >=dev-libs/libxslt-1.0.0:=
+ dev-libs/libxml2:=
+ net-libs/libsoup-gnome:2.4
+ sys-apps/hwids
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ >=dev-util/gtk-doc-am-1.10
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ # --enable-udev is only for rules.d file install
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable test tests) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ --enable-udev \
+ --disable-coverage \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-udev-rulesdir="$(get_udevdir)"/rules.d \
+ --with-usb-ids-path=/usr/share/misc/usb.ids \
+ --with-pci-ids-path=/usr/share/misc/pci.ids
+}
diff --git a/sys-libs/libosinfo/libosinfo-0.2.12.ebuild b/sys-libs/libosinfo/libosinfo-0.2.12.ebuild
new file mode 100644
index 000000000000..c42f103f3042
--- /dev/null
+++ b/sys-libs/libosinfo/libosinfo-0.2.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 udev vala
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="http://libosinfo.org/"
+SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+IUSE="+introspection +vala test"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+RDEPEND="
+ >=dev-libs/glib-2:2
+ >=dev-libs/libxslt-1.0.0:=
+ dev-libs/libxml2:=
+ net-libs/libsoup-gnome:2.4
+ sys-apps/hwids
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ >=dev-util/gtk-doc-am-1.10
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ # --enable-udev is only for rules.d file install
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable test tests) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ --enable-udev \
+ --disable-coverage \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-udev-rulesdir="$(get_udevdir)"/rules.d \
+ --with-usb-ids-path=/usr/share/misc/usb.ids \
+ --with-pci-ids-path=/usr/share/misc/pci.ids
+}
diff --git a/sys-libs/libosinfo/metadata.xml b/sys-libs/libosinfo/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/sys-libs/libosinfo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>