summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-07-13 13:42:13 -0400
committerMike Gilbert <floppym@gentoo.org>2023-07-13 13:42:13 -0400
commit3fee2ede81c49e8103daf6f6308f49483d24799e (patch)
treea57888ee9af15dc7985b961929478629b935d228 /sys-libs/cracklib
parentsys-apps/kmod: drop 30 (diff)
downloadgentoo-3fee2ede81c49e8103daf6f6308f49483d24799e.tar.gz
gentoo-3fee2ede81c49e8103daf6f6308f49483d24799e.tar.bz2
gentoo-3fee2ede81c49e8103daf6f6308f49483d24799e.zip
sys-libs/cracklib: drop 2.9.8, 2.9.10-r1
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-libs/cracklib')
-rw-r--r--sys-libs/cracklib/Manifest2
-rw-r--r--sys-libs/cracklib/cracklib-2.9.10-r1.ebuild134
-rw-r--r--sys-libs/cracklib/cracklib-2.9.8.ebuild123
3 files changed, 0 insertions, 259 deletions
diff --git a/sys-libs/cracklib/Manifest b/sys-libs/cracklib/Manifest
index 977596906ff7..f7c1656f60c2 100644
--- a/sys-libs/cracklib/Manifest
+++ b/sys-libs/cracklib/Manifest
@@ -1,3 +1 @@
-DIST cracklib-2.9.10.tar.bz2 620648 BLAKE2B f4ebf4aea6da81424a8b9fae9c204260f6020937b6b2b02cec13527f812e1751522a47a4432ff0a2a233eeb88fe0c8b7e7fd371f611a40bf2d34a10ddfd4fe83 SHA512 0c3856833f4c58fc1ebc63cc08b189c55e8d5722ef8cdc1cad5f717cef137a83648657e005e2d0367006b27aafa1bb63e36e7998918937733816635880c85f74
DIST cracklib-2.9.11.tar.xz 461116 BLAKE2B 46b499e465c1c268b772781a9c8ce573a5167ae2e0ac919b403acdb9a14c35140dfb53909eef6e41600e26c2f87d905b3d6d05380c66f053d091765b58a264f4 SHA512 c32e509f757344a1f0b7032ad3b6dc47a8759852a94e511c92073d85bce55f45d48c389d9eb34c993e1d61ad5c1542150672f3e8bc147148ebbb04d3319a2409
-DIST cracklib-2.9.8.tar.bz2 613017 BLAKE2B d9a5d922d6ac777b08cec9c427c0cde48666cdf67bf4136eb5866a0111b101c795dceb8e206e90bff31d1c8d26505bc1a950e8ea079562d8afd601641a7caf0c SHA512 bba1b82067156f44095b282c70c06a05e58572cde7ad2430dd24c4b42ae98be86708ea86ba8b7104aa5887e16ac90d7cf3ae613b84ab9c0f7602307d78b75371
diff --git a/sys-libs/cracklib/cracklib-2.9.10-r1.ebuild b/sys-libs/cracklib/cracklib-2.9.10-r1.ebuild
deleted file mode 100644
index aaff1f1b5172..000000000000
--- a/sys-libs/cracklib/cracklib-2.9.10-r1.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Note: ideally bump with sys-apps/cracklib-words
-
-DISTUTILS_OPTIONAL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 libtool multilib-minimal usr-ldscript
-
-MY_P=${P/_}
-DESCRIPTION="Password Checking Library"
-HOMEPAGE="https://github.com/cracklib/cracklib/"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.bz2"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="nls python static-libs zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? ( ${PYTHON_DEPS} )
- zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( virtual/libintl )
-"
-BDEPEND="
- nls? ( sys-devel/gettext )
- python? ( ${DISTUTILS_DEPS} )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.9.10-python-inc.patch
-)
-
-distutils_enable_tests unittest
-
-pkg_setup() {
- # Workaround bug #195017
- if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
- eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
- eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
- die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
- fi
-}
-
-src_prepare() {
- default
-
- # bug #269003
- elibtoolize
-
- if use python ; then
- distutils-r1_src_prepare
- fi
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- # use /usr/lib so that the dictionary is shared between ABIs
- --with-default-dict="/usr/lib/cracklib_dict"
- --without-python
- $(use_enable nls)
- $(use_enable static-libs static)
- )
-
- export ac_cv_header_zlib_h=$(usex zlib)
- export ac_cv_search_gzopen=$(usex zlib -lz no)
-
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use python ; then
- local -x CFLAGS="${CFLAGS} -DLOCALEDIR='\"${EPREFIX}/usr/share/locale\"' -DDEFAULT_CRACKLIB_DICT=\'${EPREFIX}/usr/lib/cracklib_dict\'"
- cd python || die
- distutils-r1_src_compile
- fi
-}
-
-multilib_src_test() {
- default
-
- if multilib_is_native_abi && use python ; then
- distutils-r1_src_test
- fi
-}
-
-python_test() {
- cd "${S}"/python || die
-
- # Make sure we load the freshly built library
- local -x LD_LIBRARY_PATH="${BUILD_DIR/-${EPYTHON/./_}}/lib/.libs:${BUILD_DIR}/lib:${LD_LIBRARY_PATH}"
-
- eunittest
-}
-
-multilib_src_install() {
- default
-
- # Move shared libs to /
- gen_usr_ldscript -a crack
-
- if multilib_is_native_abi && use python ; then
- cd python || die
- distutils-r1_src_install
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- find "${ED}" -type f -name "*.la" -delete || die
- rm -r "${ED}"/usr/share/cracklib || die
-
- insinto /usr/share/dict
- doins dicts/cracklib-small
-}
-
-pkg_postinst() {
- if [[ -z ${ROOT} ]] ; then
- ebegin "Regenerating cracklib dictionary"
- create-cracklib-dict "${EPREFIX}"/usr/share/dict/* > /dev/null
- eend $?
- fi
-}
diff --git a/sys-libs/cracklib/cracklib-2.9.8.ebuild b/sys-libs/cracklib/cracklib-2.9.8.ebuild
deleted file mode 100644
index c79bb03eb101..000000000000
--- a/sys-libs/cracklib/cracklib-2.9.8.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Note: ideally bump with sys-apps/cracklib-words
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1 libtool multilib-minimal usr-ldscript
-
-MY_P=${P/_}
-DESCRIPTION="Password Checking Library"
-HOMEPAGE="https://github.com/cracklib/cracklib/"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.bz2"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="nls python static-libs zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? ( ${PYTHON_DEPS} )
- zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( virtual/libintl )
-"
-BDEPEND="
- nls? ( sys-devel/gettext )
- python? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-do_python() {
- multilib_is_native_abi || return 0
- use python || return 0
-
- pushd python > /dev/null || die
- distutils-r1_src_${EBUILD_PHASE}
- popd > /dev/null || die
-}
-
-pkg_setup() {
- # Workaround bug #195017
- if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
- eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
- eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
- die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
- fi
-}
-
-src_prepare() {
- default
-
- # bug ##269003
- elibtoolize
-
- do_python
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- # use /usr/lib so that the dictionary is shared between ABIs
- --with-default-dict="/usr/lib/cracklib_dict"
- --without-python
- $(use_enable nls)
- $(use_enable static-libs static)
- )
-
- export ac_cv_header_zlib_h=$(usex zlib)
- export ac_cv_search_gzopen=$(usex zlib -lz no)
-
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
- default
-
- do_python
-}
-
-multilib_src_test() {
- default
-
- # Make sure we load the freshly built library
- LD_LIBRARY_PATH="${BUILD_DIR}/lib/.libs:${LD_LIBRARY_PATH}" do_python
-}
-
-python_test() {
- ${EPYTHON} -m unittest test_cracklib || die "Tests fail with ${EPYTHON}"
-}
-
-multilib_src_install() {
- default
-
- # Move shared libs to /
- gen_usr_ldscript -a crack
-
- do_python
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- find "${ED}" -type f -name "*.la" -delete || die
- rm -r "${ED}"/usr/share/cracklib || die
-
- insinto /usr/share/dict
- doins dicts/cracklib-small
-}
-
-pkg_postinst() {
- if [[ -z ${ROOT} ]] ; then
- ebegin "Regenerating cracklib dictionary"
- create-cracklib-dict "${EPREFIX}"/usr/share/dict/* > /dev/null
- eend $?
- fi
-}