summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-13 15:51:38 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 15:51:38 +0200
commit98210cd2cbc3c43e2088149a293d9d4b2808017a (patch)
treef007c942409fdc82869e048a6185068a1a2ce4da /sys-fs
parentsys-fs/nilfs-utils: drop 2.1.6 (EAPI 5) (diff)
downloadgentoo-98210cd2cbc3c43e2088149a293d9d4b2808017a.tar.gz
gentoo-98210cd2cbc3c43e2088149a293d9d4b2808017a.tar.bz2
gentoo-98210cd2cbc3c43e2088149a293d9d4b2808017a.zip
sys-fs/vzquota: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/vzquota/vzquota-3.1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/sys-fs/vzquota/vzquota-3.1.ebuild b/sys-fs/vzquota/vzquota-3.1.ebuild
index 342d9e6b24ef..cddea014503f 100644
--- a/sys-fs/vzquota/vzquota-3.1.ebuild
+++ b/sys-fs/vzquota/vzquota-3.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -12,19 +12,22 @@ SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ia64 ~ppc64 ~sparc x86"
-IUSE=""
src_prepare() {
+ default
+
sed -e 's,$(INSTALL) -s -m,$(INSTALL) -m,' \
-e 's:$(CC) $(CFLAGS) -o:$(CC) $(CFLAGS) $(LDFLAGS) -o:' \
-e 's:-Werror ::' \
- -i "${S}/src/Makefile" || die 'sed on src/Makefile failed'
+ -i "${S}/src/Makefile" || die "sed on src/Makefile failed"
+
tc-export CC
}
src_install() {
emake DESTDIR="${ED}" INSTALL="${EPREFIX}/usr/bin/install" install
keepdir /var/vzquota
+
# remove accidentally created man8 dir
- rm -r "${ED}/man8" || die 'remove man8 directory failed'
+ rm -r "${ED}/man8" || die "remove man8 directory failed"
}