summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-05-10 16:48:52 -0700
committerSam James <sam@gentoo.org>2022-05-11 02:07:07 +0000
commit18950b1eba7d8fdf98cf2795092b9c062f6536ad (patch)
tree5ba517ac270603e62a4330117aa5d9eff2dca933 /sys-fs/udisks/udisks-2.9.4.ebuild
parentmedia-sound/mumble: backport upstream fixes for new Poco, GCC 12 (diff)
downloadgentoo-18950b1eba7d8fdf98cf2795092b9c062f6536ad.tar.gz
gentoo-18950b1eba7d8fdf98cf2795092b9c062f6536ad.tar.bz2
gentoo-18950b1eba7d8fdf98cf2795092b9c062f6536ad.zip
sys-fs/udisks: Fix undefined references
When building with slibtool the build fails with undefined references. This is because slibtool respects -no-undefined while GNU libtool silently ignores it. Adding the missing dependency fixes the issue. Bug: https://bugs.gentoo.org/782061 Upstream-PR: https://github.com/storaged-project/udisks/pull/978 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/25433 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/udisks/udisks-2.9.4.ebuild')
-rw-r--r--sys-fs/udisks/udisks-2.9.4.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-fs/udisks/udisks-2.9.4.ebuild b/sys-fs/udisks/udisks-2.9.4.ebuild
index 3112d930e977..a939ae965757 100644
--- a/sys-fs/udisks/udisks-2.9.4.ebuild
+++ b/sys-fs/udisks/udisks-2.9.4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit bash-completion-r1 linux-info systemd tmpfiles udev xdg-utils
+inherit autotools bash-completion-r1 linux-info systemd tmpfiles udev xdg-utils
DESCRIPTION="Daemon providing interfaces to work with storage devices"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/udisks"
@@ -61,6 +61,10 @@ BDEPEND="
DOCS=( AUTHORS HACKING NEWS README.md )
+PATCHES=(
+ "${FILESDIR}/${P}-undefined.patch" # 782061
+)
+
pkg_setup() {
# Listing only major arch's here to avoid tracking kernel's defconfig
if use amd64 || use arm || use ppc || use ppc64 || use x86; then
@@ -79,6 +83,9 @@ src_prepare() {
if ! use systemd ; then
sed -i -e 's:libsystemd-login:&disable:' configure || die
fi
+
+ # Added for bug # 782061
+ eautoreconf
}
src_configure() {