summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-02-28 19:56:02 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-02-28 20:07:16 -0500
commit14fc76ae0ade2b986ca8d73a35e5383e0a81372b (patch)
treefa9d0ce9faa4736b274fb1c74b947f1b91ce78bb /sys-fs/f2fs-tools
parentsys-devel/automake: Rev bump to remove Python 2.7 dependency for FEATURES=-test (diff)
downloadgentoo-14fc76ae0ade2b986ca8d73a35e5383e0a81372b.tar.gz
gentoo-14fc76ae0ade2b986ca8d73a35e5383e0a81372b.tar.bz2
gentoo-14fc76ae0ade2b986ca8d73a35e5383e0a81372b.zip
sys-fs/f2fs-tools: version bump to 1.10.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-fs/f2fs-tools')
-rw-r--r--sys-fs/f2fs-tools/Manifest1
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/Manifest b/sys-fs/f2fs-tools/Manifest
index b21abced7744..1e590d9c2882 100644
--- a/sys-fs/f2fs-tools/Manifest
+++ b/sys-fs/f2fs-tools/Manifest
@@ -1,3 +1,4 @@
+DIST f2fs-tools-1.10.0.tar.xz 342904 BLAKE2B ba4dec55e11959b2dd9461b1b02d173c7766908bfdbca9f6da7aa134b4a3b5cf2bda3c2e380b3fab46afdda0be9181ae5fe85ed9d085f816a1ff96e847e2a836 SHA512 e6e9fc10bd8051db86880c415ceb50900bf0cc919f1d9fe39026b5320de7c93cbcc1d817fab73130817042ed551fc5fd55ef9b589caeca9fca63fd3098f7a853
DIST f2fs-tools-1.6.1.tar.xz 282152 BLAKE2B f8535a5415e012834b749bba2123151d8a39c8fa757905c45be20478d6a795ff64dfbcf0cf9679f2bd70cb1d92717d8df70efb4beb4d749677a6c8758ebdde0e SHA512 108327042079d9e864899a20f2dd94019be1b957fd7ffa295af097c5b93a5065ea9c36de9bae83f84a6412ac496340849fc44de041e24461a2919073eed15cf2
DIST f2fs-tools-1.8.0.tar.xz 301108 BLAKE2B b3c0eebcb4a462c97c01586b46b6b4739c2ebfaf535d146508e9fec6e4fbe442883b89d785d35993fc828eccddf177534dccb449790353557fea2f9f1c6fe24c SHA512 aff27e1113cc3034194e496883570143bd6a3cc7cc077e868255052298a401cc36c423579b4e695fe3e480d770ae05f9d14d9bb4bbc0311bdd5e23e37950a27f
DIST f2fs-tools-1.9.0.tar.xz 337676 BLAKE2B 4c6895f5faabed427db32c846df462c588acb5ec3cb45d318c1c71d2e5f241047d6871d0bbfa99116b23c26b9223069dc224f4b97c3253a283d79234b2ddd41e SHA512 aa76d4bf595b3d17607846f2531327f2c26c8724b4fdb2572074e028965c2300fcd880d57246f5c15d8dd4b9ae62fc93552edecdd504d7313fca5839590f16e5
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
new file mode 100644
index 000000000000..94561df90d65
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="selinux"
+
+RDEPEND="
+ sys-apps/util-linux
+ selinux? ( sys-libs/libselinux )"
+DEPEND="$RDEPEND"
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --disable-static \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}