summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-05-13 11:58:49 -0700
committerZac Medico <zmedico@gentoo.org>2019-05-13 12:07:57 -0700
commit791956e26824259daab9202c57a9a815ef486c5c (patch)
treefa3e7ac94a9bd499ad64ca3d4b70865ae4a747da /sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild
parentdev-db/mariadb: Fix pkg_config issues when multiple values exist (diff)
downloadgentoo-791956e26824259daab9202c57a9a815ef486c5c.tar.gz
gentoo-791956e26824259daab9202c57a9a815ef486c5c.tar.bz2
gentoo-791956e26824259daab9202c57a9a815ef486c5c.zip
sys-fabric/mstflint: version bump to 4.11.0_p5
Bug: https://bugs.gentoo.org/685430 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild')
-rw-r--r--sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild b/sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild
new file mode 100644
index 000000000000..5b269215f95b
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="840c9c2193fe9145ab177b6e891fd535e1881b43"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="${HOMEPAGE}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="inband ssl"
+SLOT="0"
+RDEPEND="dev-db/sqlite:3
+ sys-libs/zlib:=
+ inband? ( sys-fabric/libibmad )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband) $(use_enable ssl openssl)
+ # /usr/bin/install: cannot create regular file '/var/tmp/portage/.../dev_mgt.py': File exists
+ sed -e 's:^dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py:dev_mgt_pylib_DATA = c_dev_mgt.so:' -i dev_mgt/Makefile || die
+}