summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-31 13:08:48 +0100
committerSam James <sam@gentoo.org>2023-07-31 13:09:03 +0100
commit6ad5319033e13e9cf1a8372df7a91798c4c60f89 (patch)
treed80b313a479a93ee685c416ad8c92093b01ee11a /sys-cluster
parentkde-apps/kitinerary: Restrict tests (diff)
downloadgentoo-6ad5319033e13e9cf1a8372df7a91798c4c60f89.tar.gz
gentoo-6ad5319033e13e9cf1a8372df7a91798c4c60f89.tar.bz2
gentoo-6ad5319033e13e9cf1a8372df7a91798c4c60f89.zip
sys-cluster/glusterfs: always install bash-completion manually
I wanted to do a very quick hacky fix in 03b9c8a35924f482ff41b1418c9ab13979fd1c99, but here's the better one. Bug: https://bugs.gentoo.org/911523 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/glusterfs/glusterfs-11.0.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/sys-cluster/glusterfs/glusterfs-11.0.ebuild b/sys-cluster/glusterfs/glusterfs-11.0.ebuild
index eb29d14d963a..d20ce8ba2b97 100644
--- a/sys-cluster/glusterfs/glusterfs-11.0.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-11.0.ebuild
@@ -123,16 +123,11 @@ src_test() {
}
src_install() {
- local bashcompdir=$(get_bashcompdir)
- bashcompdir="${bashcompdir}" default
-
- # XXX: Quick hack to fix bug #911523
- if [[ -f "${ED}"/${bashcompdir}/gluster.bash ]] ; then
- mv "${ED}/${bashcompdir}/gluster.bash" "${ED}/${bashcompdir}/gluster" || die
- else
- newbashcomp "${ED}"/etc/bash_completion.d/gluster.bash ${PN}
- rm -rf "${ED}"/etc/bash_completion.d || die
- fi
+ default
+
+ # Path changes based on whether app-shells/bash-completion is installed, bug #911523
+ rm -rf "${ED}"/etc/bash_completion.d || die
+ newbashcomp extras/command-completion/gluster.bash ${PN}
rm \
"${ED}"/etc/glusterfs/glusterfs-{georep-,}logrotate \