summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2018-06-01 11:21:37 -0600
committerChristoph Junghans <junghans@gentoo.org>2018-06-01 11:21:52 -0600
commit6af00c88f8b6ecbfdabba748b9b9892cba5c53ea (patch)
treed3059d54f1d07daac2e942374a2b907ce8824c27 /sys-cluster/legion/legion-18.02.0.ebuild
parentnet-vpn/wireguard: use toolchain's CC and LD explicitly (diff)
downloadgentoo-6af00c88f8b6ecbfdabba748b9b9892cba5c53ea.tar.gz
gentoo-6af00c88f8b6ecbfdabba748b9b9892cba5c53ea.tar.bz2
gentoo-6af00c88f8b6ecbfdabba748b9b9892cba5c53ea.zip
sys-cluster/legion: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-cluster/legion/legion-18.02.0.ebuild')
-rw-r--r--sys-cluster/legion/legion-18.02.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-cluster/legion/legion-18.02.0.ebuild b/sys-cluster/legion/legion-18.02.0.ebuild
new file mode 100644
index 000000000000..51357e884176
--- /dev/null
+++ b/sys-cluster/legion/legion-18.02.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+if [[ $PV = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="gasnet +hwloc test"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( sys-apps/hwloc )
+ "
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DLegion_ENABLE_TESTING=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+ cmake-utils_src_configure
+}