summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-10-26 16:25:49 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-10-26 16:26:23 -0400
commitfd205ea13d9f7998b8de9b5311d0dcb1c278f76d (patch)
tree3d679c031fa350a1a28035eef1d277cdb78c18e4 /sys-boot
parentmedia-gfx/slic3r: x86 stable (bug #632664) (diff)
downloadgentoo-fd205ea13d9f7998b8de9b5311d0dcb1c278f76d.tar.gz
gentoo-fd205ea13d9f7998b8de9b5311d0dcb1c278f76d.tar.bz2
gentoo-fd205ea13d9f7998b8de9b5311d0dcb1c278f76d.zip
sys-boot/grub-0.97-r17: switch -nopie for -no-pie on gcc6+
As the -nopie option was something gentoo patched into gcc via the pie patches used for hardened, and these patches are not applied to gcc6, the no-pie patch used with grub:0 needs to be adjusted to hse the new flag when a newer gcc is used. Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-0.97-r17.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-boot/grub/grub-0.97-r17.ebuild b/sys-boot/grub/grub-0.97-r17.ebuild
index 038a541f8795..b34191f7346d 100644
--- a/sys-boot/grub/grub-0.97-r17.ebuild
+++ b/sys-boot/grub/grub-0.97-r17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
@@ -67,6 +67,13 @@ src_prepare() {
"${S}"/grub/asmstub.c \
|| die
+ # gcc-6 and above doesnt have a '-nopie' option patched in, use upstream's -no-pie
+ if (( $(gcc-major-version) > 5 )); then
+ sed -i 's/-nopie/-no-pie/' \
+ "${WORKDIR}"/patch/860_all_grub-0.97-pie.patch \
+ || die
+ fi
+
EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
# bug 564890, 566638
epatch "${FILESDIR}"/grub-0.97-Add-esp-to-list-of-clobbered-registers.patch