summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDouglas Freed <dwfreed@mtu.edu>2016-06-28 21:43:11 -0400
committerMike Gilbert <floppym@gentoo.org>2016-06-28 21:52:15 -0400
commitd61119fb4ea2112ed2f08be53566d75b4b325e97 (patch)
treee0a1cc38aca35d4f2eeb92bd1066e8c3141a703d /sys-boot
parentwww-client/chromium: use chromium-2.eclass (diff)
downloadgentoo-d61119fb4ea2112ed2f08be53566d75b4b325e97.tar.gz
gentoo-d61119fb4ea2112ed2f08be53566d75b4b325e97.tar.bz2
gentoo-d61119fb4ea2112ed2f08be53566d75b4b325e97.zip
sys-boot/grub: add xen-32 platform
This builds 32-bit Xen on amd64. Bug: https://bugs.gentoo.org/586996
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-2.02_beta3-r1.ebuild8
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/sys-boot/grub/grub-2.02_beta3-r1.ebuild b/sys-boot/grub/grub-2.02_beta3-r1.ebuild
index 7fd67ee9e04f..fd6f5f2d802f 100644
--- a/sys-boot/grub/grub-2.02_beta3-r1.ebuild
+++ b/sys-boot/grub/grub-2.02_beta3-r1.ebuild
@@ -51,7 +51,7 @@ LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
IUSE="debug device-mapper doc efiemu +fonts mount +multislot nls static sdl test +themes truetype libzfs"
-GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen )
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
REQUIRED_USE="
@@ -85,6 +85,7 @@ DEPEND="${RDEPEND}
sys-apps/texinfo
fonts? ( media-libs/freetype:2 )
grub_platforms_xen? ( app-emulation/xen-tools:= )
+ grub_platforms_xen-32? ( app-emulation/xen-tools:= )
static? (
app-arch/xz-utils[static-libs(+)]
truetype? (
@@ -180,6 +181,11 @@ grub_configure() {
local TARGET_CPPFLAGS="-march=x86-64 ${TARGET_CPPFLAGS}"
export TARGET_CFLAGS TARGET_CPPFLAGS
fi ;;
+ xen-32)
+ platform=xen
+ if [[ ${CHOST} == x86_64* ]]; then
+ local CTARGET=i386
+ fi ;;
guessed) ;;
*) platform=${MULTIBUILD_VARIANT} ;;
esac
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index c880d12e4920..b0c7084c38c5 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -48,7 +48,7 @@ LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
IUSE="debug device-mapper doc efiemu +fonts mount +multislot nls static sdl test +themes truetype libzfs"
-GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen )
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
REQUIRED_USE="
@@ -82,6 +82,7 @@ DEPEND="${RDEPEND}
sys-apps/texinfo
fonts? ( media-libs/freetype:2 )
grub_platforms_xen? ( app-emulation/xen-tools:= )
+ grub_platforms_xen-32? ( app-emulation/xen-tools:= )
static? (
app-arch/xz-utils[static-libs(+)]
truetype? (
@@ -181,6 +182,11 @@ grub_configure() {
local TARGET_CPPFLAGS="-march=x86-64 ${TARGET_CPPFLAGS}"
export TARGET_CFLAGS TARGET_CPPFLAGS
fi ;;
+ xen-32)
+ platform=xen
+ if [[ ${CHOST} == x86_64* ]]; then
+ local CTARGET=i386
+ fi ;;
guessed) ;;
*) platform=${MULTIBUILD_VARIANT} ;;
esac