summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-07-05 15:53:50 +0200
committerUlrich Müller <ulm@gentoo.org>2018-07-05 15:53:50 +0200
commit4bf27313d39ee0f7dbff576718cb855500d74fd9 (patch)
tree3652f02d555d4576e5113abda816c1fa6588d694 /sys-boot
parentsci-physics/root: add missing dependency on numpy with USE=tmva (diff)
downloadgentoo-4bf27313d39ee0f7dbff576718cb855500d74fd9.tar.gz
gentoo-4bf27313d39ee0f7dbff576718cb855500d74fd9.tar.bz2
gentoo-4bf27313d39ee0f7dbff576718cb855500d74fd9.zip
sys-boot/systemrescuecd-x86-grub: Fix path of ISO image.
Also bump EAPI to 7. Non-maintainer commit. Acked by mgorny. Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/systemrescuecd-x86-grub/files/systemrescuecd.grub10
-rw-r--r--sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1-r1.ebuild (renamed from sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild)5
2 files changed, 7 insertions, 8 deletions
diff --git a/sys-boot/systemrescuecd-x86-grub/files/systemrescuecd.grub b/sys-boot/systemrescuecd-x86-grub/files/systemrescuecd.grub
index e9695c4b4821..269b1eb76adb 100644
--- a/sys-boot/systemrescuecd-x86-grub/files/systemrescuecd.grub
+++ b/sys-boot/systemrescuecd-x86-grub/files/systemrescuecd.grub
@@ -1,5 +1,5 @@
#!/bin/sh
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
. /usr/share/grub/grub-mkconfig_lib
@@ -32,28 +32,28 @@ if [ -f "${srcd}" ]; then
submenu "${longname}" --class submenu {
menuentry "${longname} (32bit standard${bootops}" --class rescue {
${grub_string}
- set isofile=${srcd}
+ set isofile=${path}
loopback loop \${isofile}
linux (loop)/isolinux/rescue32 ${SRCD_BOOTOPTIONS} isoloop=\${isofile}
initrd (loop)/isolinux/initram.igz
}
menuentry "${longname} (64bit standard${bootops}" --class rescue {
${grub_string}
- set isofile=${srcd}
+ set isofile=${path}
loopback loop \${isofile}
linux (loop)/isolinux/rescue64 ${SRCD_BOOTOPTIONS} isoloop=\${isofile}
initrd (loop)/isolinux/initram.igz
}
menuentry "${longname} (32bit alternative${bootops}" --class rescue {
${grub_string}
- set isofile=${srcd}
+ set isofile=${path}
loopback loop \${isofile}
linux (loop)/isolinux/altker32 ${SRCD_BOOTOPTIONS} isoloop=\${isofile}
initrd (loop)/isolinux/initram.igz
}
menuentry "${longname} (64bit alternative${bootops}" --class rescue {
${grub_string}
- set isofile=${srcd}
+ set isofile=${path}
loopback loop \${isofile}
linux (loop)/isolinux/altker64 ${SRCD_BOOTOPTIONS} isoloop=\${isofile}
initrd (loop)/isolinux/initram.igz
diff --git a/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild b/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1-r1.ebuild
index 3a5d11ae858b..80a820419133 100644
--- a/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1.ebuild
+++ b/sys-boot/systemrescuecd-x86-grub/systemrescuecd-x86-grub-0.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="Grub menu entries for the .iso image of systemrescuecd-x86"
HOMEPAGE="http://www.sysresccd.org/"
@@ -10,7 +10,6 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT=0
KEYWORDS="~amd64 ~x86"
-IUSE=""
S=${WORKDIR}