summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-10-01 11:17:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-10-01 11:18:16 -0500
commita6c0e68cc574d9727f32775068978dc4e9fa542e (patch)
tree5f587958395b854bd72aa49fb10480daf87e817e /sys-block
parentapp-emulation/diskimage-builder: stabilize 3.31.0 for amd64, x86 (diff)
downloadgentoo-a6c0e68cc574d9727f32775068978dc4e9fa542e.tar.gz
gentoo-a6c0e68cc574d9727f32775068978dc4e9fa542e.tar.bz2
gentoo-a6c0e68cc574d9727f32775068978dc4e9fa542e.zip
sys-block/tgt: add 1.0.88
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/tgt/Manifest1
-rw-r--r--sys-block/tgt/tgt-1.0.88.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-block/tgt/Manifest b/sys-block/tgt/Manifest
index 4acb98a49afa..bb4cdc438f6b 100644
--- a/sys-block/tgt/Manifest
+++ b/sys-block/tgt/Manifest
@@ -1,2 +1,3 @@
DIST tgt-1.0.86.tar.gz 304697 BLAKE2B 60233019e9f09dd4288ca70f398992452dc00f7a2f46d82e333a9e1bfa4fe5dcc8583da3d4ce4382b32c60b1b009dd03d36faa9770faa11222b9ec4592bd6d96 SHA512 f4e8e87691be2793c5eee9d7dc744ae3a7b47f710f559141f0533de345f727fb68223a3090282f5c51f70ea55fbf5936d81e3b08ce953b7ac48013295c32bef7
DIST tgt-1.0.87.tar.gz 304798 BLAKE2B e8772a02078204373dd43276cc5534dd9e8996841bdfef613f34a9c59ef2886f866ff6fb56e6bdaea653b4081b477e1ab15cb3ed3d125b7c08b45ab11a63a7cb SHA512 362adfc92f9fc6528b3de0aa9f202e39f6035b92fe3078236a3f75c0aef540a82cb4594077fdc7de2e524acc75601f5696111cc9aebc6de6265c53cd1d073db2
+DIST tgt-1.0.88.tar.gz 305767 BLAKE2B d9a35da5c12ba1621473a04f59ffc85364412443854e4b9d88ba7ae7a7120dbbf6cf233852ef33cca2f19bb67acd54dcdd97041812277cc7eb9359d2483289d4 SHA512 b1ac4da634ff65edfd67cfcbd4509772216ba411b8c389cd209d3abe7c72b19f8e261c627e3ad8343faeebe3d8b758855184b50ab9e635d11c707ba3bb79fe70
diff --git a/sys-block/tgt/tgt-1.0.88.ebuild b/sys-block/tgt/tgt-1.0.88.ebuild
new file mode 100644
index 000000000000..f5b5df98b0fe
--- /dev/null
+++ b/sys-block/tgt/tgt-1.0.88.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Linux SCSI target framework (tgt)"
+HOMEPAGE="https://github.com/fujita/tgt"
+SRC_URI="https://github.com/fujita/tgt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~sparc x86"
+IUSE="fcoe fcp ibmvio infiniband rbd selinux"
+
+DEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-perl/Config-General
+ rbd? ( sys-cluster/ceph )
+ infiniband? ( sys-cluster/rdma-core )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-libs/libaio
+ sys-apps/sg3_utils
+ selinux? ( sec-policy/selinux-tgtd )
+"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ default
+ sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die
+ # make sure xml docs are generated before trying to install them
+ sed -i -e "s@install: @& all @g" doc/Makefile || die
+ sed -i -e 's|-Werror||g' usr/Makefile || die
+}
+
+src_compile() {
+ local myconf
+ use ibmvio && myconf="${myconf} IBMVIO=1"
+ use infiniband && myconf="${myconf} ISCSI_RDMA=1"
+ use fcp && myconf="${myconf} FCP=1"
+ use fcoe && myconf="${myconf} FCOE=1"
+ use rbd && myconf="${myconf} CEPH_RBD=1"
+
+ emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
+ emake -C doc
+}
+
+src_install() {
+ emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
+ newinitd "${FILESDIR}"/tgtd.initd-new tgtd
+ newconfd "${FILESDIR}"/tgtd.confd-new tgtd
+ systemd_dounit "${S}"/scripts/tgtd.service
+ dodir /etc/tgt
+ keepdir /etc/tgt
+}