summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-05 11:00:21 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-05 12:18:24 +0200
commit2f6fff4618a15305352948e7378d41971e352af3 (patch)
tree16ce4b5c4b54fd4c717df269534e8caeebb8215e /sys-auth/pam_yubico
parentnet-analyzer/wireshark: Stable for AMD64 HPPA x86 too. (diff)
downloadgentoo-2f6fff4618a15305352948e7378d41971e352af3.tar.gz
gentoo-2f6fff4618a15305352948e7378d41971e352af3.tar.bz2
gentoo-2f6fff4618a15305352948e7378d41971e352af3.zip
sys-auth/pam_yubico: Bump to version 2.25
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'sys-auth/pam_yubico')
-rw-r--r--sys-auth/pam_yubico/Manifest1
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.25.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/Manifest b/sys-auth/pam_yubico/Manifest
index 9e42a01be567..6edb78701a3a 100644
--- a/sys-auth/pam_yubico/Manifest
+++ b/sys-auth/pam_yubico/Manifest
@@ -1,2 +1,3 @@
DIST pam_yubico-2.23.tar.gz 418567 BLAKE2B 9df6a35d7ef314b58912c91ba9ad4ae792f2931fedbf4617572d06a6a0cce5cd2190002e26891a524379b8cc886a3e5e16330a03ac617aa7efc6db58b281c400 SHA512 435a5013ef7d020f8fe6d54614b22a4d3df6295adeb8e1fd26722246d105375b8d19940098b62956a18f439dad82f67e3996a7067af3357fddff380d20fa4728
DIST pam_yubico-2.24.tar.gz 418419 BLAKE2B 5ae988a3ba3244761d1fcadfc25f67a6c8cefd78d24535f4644ca469a5a1fb274832fb17e76d18376645960f532bf1107e6eb08112b4eacf1c797faf0349b5ca SHA512 3554b40d97ede9d02102a0661e732347a0ab2cb012fa4330cc8227289a03398a7b974ee9d170604dce53ebef1bedade5c7ab9d5657560b0ba8e4c65432c1112c
+DIST pam_yubico-2.25.tar.gz 422192 BLAKE2B 54f27f9a0ff64c529c74415cf4530cdd1c359325beeda4d8ce2b51af4f9b53c69284696de21a5c1e3b4eed5102571e320cf068693fbd43d144ad2c9f40c39b72 SHA512 c561bedd35d3a84cc2129f12e358b77ac425520acf13444c2918cb17c9c4158d29dc5049b2e03dd30a1f04e8568980d80af13a6a0cfd9cc8e70eee8738727d70
diff --git a/sys-auth/pam_yubico/pam_yubico-2.25.ebuild b/sys-auth/pam_yubico/pam_yubico-2.25.ebuild
new file mode 100644
index 000000000000..034bfdfc4539
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.25.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/yubico-pam"
+SRC_URI="http://opensource.yubico.com/yubico-pam/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap test"
+
+RDEPEND="
+ virtual/pam
+ sys-auth/libyubikey
+ >=sys-auth/ykclient-2.15
+ >=sys-auth/ykpers-1.6
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ test? ( dev-perl/Net-LDAP-Server )"
+
+src_configure() {
+ #challenge response could be optional but that seems horribly dangerous to me
+ local myeconfargs=(
+ --with-cr
+ --with-pam-dir=/$(get_libdir)/security
+ $(use_with ldap)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ find "${D}" -name '*.la' -delete || die
+}