summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-06-01 20:26:45 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-01 20:26:45 +0200
commit61975a03862b41f57868867e8aeec85643aa4c94 (patch)
treedefb74a51d5220520dfe45f1eaf9d9fd55c0a39c /sys-auth/pam_u2f/pam_u2f-1.1.1.ebuild
parentnet-irc/znc: fix SLOT for live ebuild (diff)
downloadgentoo-61975a03862b41f57868867e8aeec85643aa4c94.tar.gz
gentoo-61975a03862b41f57868867e8aeec85643aa4c94.tar.bz2
gentoo-61975a03862b41f57868867e8aeec85643aa4c94.zip
sys-auth/pam_u2f: add 1.1.1
Bug: https://bugs.gentoo.org/792270 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-auth/pam_u2f/pam_u2f-1.1.1.ebuild')
-rw-r--r--sys-auth/pam_u2f/pam_u2f-1.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-auth/pam_u2f/pam_u2f-1.1.1.ebuild b/sys-auth/pam_u2f/pam_u2f-1.1.1.ebuild
new file mode 100644
index 000000000000..01c9842b3bd9
--- /dev/null
+++ b/sys-auth/pam_u2f/pam_u2f-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic pam
+
+DESCRIPTION="PAM module for FIDO2 and U2F keys"
+HOMEPAGE="https://github.com/Yubico/pam-u2f"
+SRC_URI="https://developers.yubico.com/${PN/_/-}/Releases/${P}.tar.gz"
+
+LICENSE="BSD ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libfido2:=
+ dev-libs/openssl:=
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use debug || append-cppflags -UDEBUG_PAM -UPAM_DEBUG
+ econf --with-pam-dir=$(getpam_mod_dir)
+}
+
+src_install() {
+ default
+
+ # plugin only
+ find "${ED}" -name '*.la' -delete || die
+}