summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKerin Millar <kfm@plushkava.net>2024-08-11 02:52:46 +0000
committerSam James <sam@gentoo.org>2024-08-11 11:25:49 +0100
commiteaf30a2314bac219042e9ec5b283c865cc67b25f (patch)
tree2c6ea44135ab13d2039c09b315f21d4855fd9d7f /sys-apps
parentprofiles: mask cbindgen-0.27.0 (diff)
downloadgentoo-eaf30a2314bac219042e9ec5b283c865cc67b25f.tar.gz
gentoo-eaf30a2314bac219042e9ec5b283c865cc67b25f.tar.bz2
gentoo-eaf30a2314bac219042e9ec5b283c865cc67b25f.zip
sys-apps/gentoo-functions: add 1.7.2
Also, sync the version 9999 ebuild. Closes: https://bugs.gentoo.org/937463 Signed-off-by: Kerin Millar <kfm@plushkava.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gentoo-functions/Manifest1
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-1.7.2.ebuild49
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-9999.ebuild7
3 files changed, 52 insertions, 5 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index 9affe6719bdd..ded5ad314d44 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -2,4 +2,5 @@ DIST gentoo-functions-0.19.tar.bz2 12079 BLAKE2B be0a3a54d4dee1755866047b670a69c
DIST gentoo-functions-1.5.tar.bz2 15808 BLAKE2B 99c330eb4c7f1d7af67b6f93dba565f9ea37c15e82d0b97157067279671dc3918668bf8120f7c410f018d67761cee41320efaec4df43639765d023b23a3a9a7f SHA512 f7add7770f40e110864f16978e968bfd937c1a5099e336cc04f6861483bae36ff7932f502994df1ddfa347beef8736bd39bd276bafbe04190c9915446457ce15
DIST gentoo-functions-1.6.tar.bz2 16795 BLAKE2B c901cdb8f2fcb507b5397e9ce674a12641f2129b9be05776bb272e09b9db3a6d205e6a00ef51f71b3203eac4e333b297cfe5ae5d61f9dd43074073a749ca171e SHA512 922b801c79f12d15bcabdb6cd52246cc60a4b512dfcc10bb3933f07d2ec03e01fe5be72502ae34c87374c8a7e880ce268e7dc8d1afcbd28b65efb51b9e467306
DIST gentoo-functions-1.7.1.tar.bz2 26081 BLAKE2B d62259bdbce08043ce266f6ef78eeda2d103feb541526eb3c8fd692d46eec83368c8d4173b72a1dd8a3acd48f13681ef5e44544b7c185f76b325b6bb05c36e9c SHA512 67b7df5d17ac74aeec8cb6733e6270a184bb11f25c86871758835d860d3466e636f5b7660ef7ab189f3ba90ab3b14f7fb65f1c1e95cf7629220aee8e1d93c72a
+DIST gentoo-functions-1.7.2.tar.bz2 29059 BLAKE2B 2b3d13e6f5b553fd0fa7a0880677bd61c82c8815d3801a2d80e7632a97c36f81b41075109856f6248ad0eb2453b511066e63a110c97984e6427135ad19cdc234 SHA512 3839b04784576cc5c5824b24f967862ea421be051983d1ac587de7e21b0fbc4f403e0d4f707ee5cbcf466ec4a12d188da9413a81ca71993c957328ff225cb9af
DIST gentoo-functions-1.7.tar.bz2 25934 BLAKE2B f105d8dfab99d56256828ea833c1035445667d80261576a7c7ba3bc74cce64a58567a75d2dad37dff02836989bac2bd9d32f0fd87f93ca337f90eeb04889b991 SHA512 a7e8498dea93bf6f7796d25eb55fd440f9c675ef32d7c2e059bc8206adba7334b7f07b7510174e181dd88dbc9753494e3ff0fbd3c129a6f8524ee07a85edb8cf
diff --git a/sys-apps/gentoo-functions/gentoo-functions-1.7.2.ebuild b/sys-apps/gentoo-functions/gentoo-functions-1.7.2.ebuild
new file mode 100644
index 000000000000..512195ceb8c2
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-1.7.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2014-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local emesonargs=(
+ # Deliberately avoid /usr as consumers assume we're at /lib/gentoo.
+ --prefix="${EPREFIX:-/}"
+ --mandir="${EPREFIX}/usr/share/man"
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if [[ ${EPREFIX} ]]; then
+ while read -r; do
+ if [[ ${REPLY} == $'\t'genfun_prefix= ]]; then
+ printf '\tgenfun_prefix=%q\n' "${EPREFIX}"
+ else
+ printf '%s\n' "${REPLY}"
+ fi || ! break
+ done < "${ED}/lib/gentoo/functions.sh" > "${T}/functions.sh" \
+ && mv -- "${T}/functions.sh" "${ED}/lib/gentoo/functions.sh" \
+ || die
+ fi
+}
diff --git a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
index 864663a97757..512195ceb8c2 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
@@ -16,14 +16,11 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
fi
-LICENSE="GPL-2 public-domain"
+LICENSE="GPL-2"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-# Specifically needs GNU find, as well.
-RDEPEND=">=sys-apps/findutils-4.9"
-
src_configure() {
local emesonargs=(
# Deliberately avoid /usr as consumers assume we're at /lib/gentoo.
@@ -41,7 +38,7 @@ src_install() {
if [[ ${EPREFIX} ]]; then
while read -r; do
if [[ ${REPLY} == $'\t'genfun_prefix= ]]; then
- printf 'genfun_prefix=%q\n' "${EPREFIX}"
+ printf '\tgenfun_prefix=%q\n' "${EPREFIX}"
else
printf '%s\n' "${REPLY}"
fi || ! break