summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-06 12:43:26 +0100
committerSam James <sam@gentoo.org>2023-08-06 12:48:37 +0100
commitcc9abc19ceb0c3bb7d2632394c38f4772f490ca8 (patch)
treeb1aae3a04bf710eb0653c028a1ce9c530d1c7274 /sys-apps
parentdev-qt/qtcore: use tc-enables-fortify-source (diff)
downloadgentoo-cc9abc19ceb0c3bb7d2632394c38f4772f490ca8.tar.gz
gentoo-cc9abc19ceb0c3bb7d2632394c38f4772f490ca8.tar.bz2
gentoo-cc9abc19ceb0c3bb7d2632394c38f4772f490ca8.zip
sys-apps/acl: use tc-enables-fortify-source
Better than fragile optimisation level checking. Bug: https://bugs.gentoo.org/841770 Bug: https://bugs.gentoo.org/847280 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/acl/acl-2.3.1-r1.ebuild6
-rw-r--r--sys-apps/acl/acl-2.3.1-r2.ebuild6
2 files changed, 4 insertions, 8 deletions
diff --git a/sys-apps/acl/acl-2.3.1-r1.ebuild b/sys-apps/acl/acl-2.3.1-r1.ebuild
index c167d5b8ae70..371710aeb2ee 100644
--- a/sys-apps/acl/acl-2.3.1-r1.ebuild
+++ b/sys-apps/acl/acl-2.3.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic libtool multilib-minimal usr-ldscript
+inherit flag-o-matic libtool multilib-minimal toolchain-funcs usr-ldscript
DESCRIPTION="Access control list utilities, libraries, and headers"
HOMEPAGE="https://savannah.nongnu.org/projects/acl"
@@ -42,9 +42,7 @@ multilib_src_configure() {
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104964
# https://savannah.nongnu.org/bugs/index.php?62519
# bug #847280
- if is-flagq '-O[23]' || is-flagq '-Ofast' ; then
- # We can't unconditionally do this b/c we fortify needs
- # some level of optimisation.
+ if tc-enables-fortify-source ; then
filter-flags -D_FORTIFY_SOURCE=3
append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
fi
diff --git a/sys-apps/acl/acl-2.3.1-r2.ebuild b/sys-apps/acl/acl-2.3.1-r2.ebuild
index e94a237871d1..d89fd34d6a13 100644
--- a/sys-apps/acl/acl-2.3.1-r2.ebuild
+++ b/sys-apps/acl/acl-2.3.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic libtool multilib-minimal usr-ldscript
+inherit flag-o-matic libtool multilib-minimal toolchain-funcs usr-ldscript
DESCRIPTION="Access control list utilities, libraries, and headers"
HOMEPAGE="https://savannah.nongnu.org/projects/acl"
@@ -46,9 +46,7 @@ multilib_src_configure() {
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104964
# https://savannah.nongnu.org/bugs/index.php?62519
# bug #847280
- if is-flagq '-O[23]' || is-flagq '-Ofast' ; then
- # We can't unconditionally do this b/c we fortify needs
- # some level of optimisation.
+ if tc-enables-fortify-source ; then
filter-flags -D_FORTIFY_SOURCE=3
append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
fi