summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-02 00:19:55 +0000
committerSam James <sam@gentoo.org>2024-02-02 01:01:19 +0000
commitcb284ad8359619ed9315ef28e839e711ebe04bb4 (patch)
tree69f5c1d4ba8720390038ea61119c1454bc323441 /sys-apps
parentapp-shells/fzf: add 0.46.1 (diff)
downloadgentoo-cb284ad8359619ed9315ef28e839e711ebe04bb4.tar.gz
gentoo-cb284ad8359619ed9315ef28e839e711ebe04bb4.tar.bz2
gentoo-cb284ad8359619ed9315ef28e839e711ebe04bb4.zip
sys-apps/moar: add 1.23.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.23.4.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index f4da6fd0b5e7..2747dcd9c99d 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -4,3 +4,5 @@ DIST moar-1.22.3-deps.tar.xz 61027724 BLAKE2B ba22db246b20f4a6b28c19a3654f1b1cd6
DIST moar-1.22.3.tar.gz 2799819 BLAKE2B 681297e9a84f6846d7ea6cd591403fd3100079fc8418ce5841a50755927239eca5abbfc0477d1a74e3af687ef1ebe372d4f708c38a64ba61b3095ac161f1cb8e SHA512 377cdf4916b036088f48abd4aa9818f002dd5ab025a54f4d91626380bb3d370daf046da6f3dc31fcc11a375d7da1a84288fb3e2e3357181a6ecc6a46af78c452
DIST moar-1.23.1-deps.tar.xz 61027724 BLAKE2B ba22db246b20f4a6b28c19a3654f1b1cd68e0a92aff43ff02a592b303ff3318c3766381bd4b0abff5f479fe571b753a272213d7dc7da809a33ded36228dac100 SHA512 a1be9f66480867faa06fb451bcc6a294bb1e2e4601c97c1beac67a3f866104b196ecd2653dc9ddd48a5223d4f3067a01abbaf45fc07333d97c4f8489424ff5cf
DIST moar-1.23.1.tar.gz 2801572 BLAKE2B 535a574e421d25d0b1452ba0b345e7e8291db76e058f33f1a8a045732e7a79a56e9b681e9a01ecd6d023fe63fc215648a1c91daeeaff1b8856a54d716baa2053 SHA512 bf06709e95299648eadec86ac6af1d91449268efc7d6a9aaa74a26c54a28a6edfebecf0e7a6921fe7c509646361ff0c9e624e53a37ce577a469c52f5cfc040b6
+DIST moar-1.23.4-deps.tar.xz 61027724 BLAKE2B ba22db246b20f4a6b28c19a3654f1b1cd68e0a92aff43ff02a592b303ff3318c3766381bd4b0abff5f479fe571b753a272213d7dc7da809a33ded36228dac100 SHA512 a1be9f66480867faa06fb451bcc6a294bb1e2e4601c97c1beac67a3f866104b196ecd2653dc9ddd48a5223d4f3067a01abbaf45fc07333d97c4f8489424ff5cf
+DIST moar-1.23.4.tar.gz 2801843 BLAKE2B 93b0ce5159d0b3b244716e0643f2ff9ac27f7179ab116a3be037c5efc16d78e37e92c2367181ecc28e641048b3768acf584911acee1c8f4eeee28ad32f574bba SHA512 55e2d24d8ccef2d8b0582027b70527500aec9fc24f8dd03a90677e2743742f9fa0e664e5cad6a8630d8bb47b402ef54778a4efc656b102afec7578ffd62d3bfe
diff --git a/sys-apps/moar/moar-1.23.4.ebuild b/sys-apps/moar/moar-1.23.4.ebuild
new file mode 100644
index 000000000000..7ba82f9aa27b
--- /dev/null
+++ b/sys-apps/moar/moar-1.23.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}