summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-11-10 13:55:22 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-11-11 09:56:45 +0100
commit73bbf5c9464fb3ab17a72c1dc653015d0aa15605 (patch)
tree3c90da1be2f916d0b75fc94ea251876cb999d577 /sys-apps
parentdev-python/qdarkstyle: Remove old (diff)
downloadgentoo-73bbf5c9464fb3ab17a72c1dc653015d0aa15605.tar.gz
gentoo-73bbf5c9464fb3ab17a72c1dc653015d0aa15605.tar.bz2
gentoo-73bbf5c9464fb3ab17a72c1dc653015d0aa15605.zip
sys-apps/irqbalance: add 1.9.3
The new version introduces the 'thermal' USE flag with according optfeature and installs irqbalance's udev rule. Closes: https://github.com/gentoo/gentoo/pull/33754 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/irqbalance/Manifest1
-rw-r--r--sys-apps/irqbalance/irqbalance-1.9.3.ebuild74
-rw-r--r--sys-apps/irqbalance/metadata.xml1
3 files changed, 76 insertions, 0 deletions
diff --git a/sys-apps/irqbalance/Manifest b/sys-apps/irqbalance/Manifest
index bd18e55b42f0..e5aa80c92da6 100644
--- a/sys-apps/irqbalance/Manifest
+++ b/sys-apps/irqbalance/Manifest
@@ -1 +1,2 @@
DIST irqbalance-1.9.2.tar.gz 62188 BLAKE2B bc640323c3a594090f77983e63d9b7df177a05b859e4d29edb5b654f886c9e9f0d748ce22b1323bee443ea8369e014b9e0ce383bfe6f396692346649199d10a2 SHA512 d0fb157fbfc096fa9cfb4562e51fd4c3f4fa8788f72377c58b27df67c70073b787bba05e39809dcbe17532bb5b8e74b6d27c5e5b3d9af09bc9ce1a9b6aab9378
+DIST irqbalance-1.9.3.tar.gz 62573 BLAKE2B 0f7b3b62c3784c009c6829078cdf5496910ec3f3c8c13de5f0dfbaed510fb5e3dab4953810c646ece962ef130af3aaa0bb9fa8c2e013485751cc661c9458e87a SHA512 5638fb59f5a59901333b90289ee70c960df0e2b9e55731805397797b8e630bb3703e36a4dfd05bf01de49334dab9d6fc95bde4967eeab131534950d281103fa1
diff --git a/sys-apps/irqbalance/irqbalance-1.9.3.ebuild b/sys-apps/irqbalance/irqbalance-1.9.3.ebuild
new file mode 100644
index 000000000000..066d36bb150d
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.9.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools udev systemd linux-info optfeature
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="https://github.com/Irqbalance/irqbalance"
+SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="caps +numa systemd selinux thermal tui"
+# Hangs
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/glib:2
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )
+ systemd? ( sys-apps/systemd:= )
+ thermal? ( dev-libs/libnl:3 )
+ tui? ( sys-libs/ncurses:=[unicode(+)] )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-irqbalance )
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~PCI_MSI"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ # Follow systemd policies
+ # https://wiki.gentoo.org/wiki/Project:Systemd/Ebuild_policy
+ sed \
+ -e 's/ $IRQBALANCE_ARGS//' \
+ -e '/EnvironmentFile/d' \
+ -i misc/irqbalance.service || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with caps libcap-ng)
+ $(use_enable numa)
+ $(use_with systemd)
+ $(use_enable thermal)
+ $(use_with tui irqbalance-ui)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/irqbalance.init.4 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_dounit misc/irqbalance.service
+ udev_dorules misc/90-irqbalance.rules
+}
+
+pkg_postinst() {
+ optfeature "thermal events support (requires USE=thermal)" sys-power/thermald
+}
diff --git a/sys-apps/irqbalance/metadata.xml b/sys-apps/irqbalance/metadata.xml
index 6e8113310952..170316cf57a9 100644
--- a/sys-apps/irqbalance/metadata.xml
+++ b/sys-apps/irqbalance/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="numa">Support balancing IRQs across NUMA nodes</flag>
+ <flag name="thermal">Enable support of thermal events via <pkg>sys-power/thermald</pkg></flag>
<flag name="tui">Enable build of irqbalance terminal user interface</flag>
</use>
<upstream>