summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-01 09:04:01 +0100
committerSam James <sam@gentoo.org>2023-09-01 09:04:01 +0100
commit42b7887c819944c5ad9fe7e83db5fffd9bd99d7f (patch)
treefd6ab03e7b36b9782a3d9b63751969392517b00d /sys-apps
parentapp-misc/ca-certificates: add 20230311.3.93 (diff)
downloadgentoo-42b7887c819944c5ad9fe7e83db5fffd9bd99d7f.tar.gz
gentoo-42b7887c819944c5ad9fe7e83db5fffd9bd99d7f.tar.bz2
gentoo-42b7887c819944c5ad9fe7e83db5fffd9bd99d7f.zip
sys-apps/moar: add 1.16.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.16.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index cd9567227ecf..596166af4c95 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -2,3 +2,5 @@ DIST moar-1.15.3-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652
DIST moar-1.15.3.tar.gz 2781596 BLAKE2B 36e908245fbdebb89e2ed5cc1ef80c2000aeb03d8f35b84dff6d7e8b270d337d3dec9829d718d576e6ca4b0a6ac8694c5fa72b167a67dd3e7cde97ff06f7bfc5 SHA512 cce9eef06af14c320527a1b6a1832608b8267b9453eafb1153677aea98372e3fc3800e2a8938e9460e0f914c72f5c31380a0ee8ff0bd7db903756bea5352b424
DIST moar-1.15.4-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652c760818cdee66bb8475cc8949872c82be026c04b54cb61c0108c5977cb1f787f9a4fa0316bde0293cdedb1f6f94f8 SHA512 f40520a1b2e94f4a3e97d6a4e19191484b66e13a57c7b30416c813d84cad3d29295e862d5b75870313cc905112425c731d052619d49e78b33fb3d5d8750df3df
DIST moar-1.15.4.tar.gz 2782491 BLAKE2B 467429bbc9dae085065ebc17e1b8b56ebe67b0cd8f4675a72f9032150513876f66dbddf4a3e9baa8d921cbb0779aea24b51a10f9af628c64724313aa60ab4ecc SHA512 c4068fbf1a8ea64d8a169f2aa8e73d6dedc4cc781ebd011dcdae4093f277843566f88d4e087417f3e02097e252653e487547b8dbe6889dd06a5d9956c9b93a67
+DIST moar-1.16.0-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652c760818cdee66bb8475cc8949872c82be026c04b54cb61c0108c5977cb1f787f9a4fa0316bde0293cdedb1f6f94f8 SHA512 f40520a1b2e94f4a3e97d6a4e19191484b66e13a57c7b30416c813d84cad3d29295e862d5b75870313cc905112425c731d052619d49e78b33fb3d5d8750df3df
+DIST moar-1.16.0.tar.gz 2782723 BLAKE2B 9a715de13bb522b4aae1940dcd7a017a3f31c50c13a7f3463447318843c9dafc51539450cbaf4adb773966a48cc5d7c04955492d6a0fc18fce1bd219172bf51e SHA512 92321b6eea8609ea02a0955d0ea5fa8f362c51260e62f3a23384663ffaa269183c57d4258235400191b61c056b5dbed7bdb86710f2fe57ec97af2dca12f754e9
diff --git a/sys-apps/moar/moar-1.16.0.ebuild b/sys-apps/moar/moar-1.16.0.ebuild
new file mode 100644
index 000000000000..a32bbea5ec05
--- /dev/null
+++ b/sys-apps/moar/moar-1.16.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI=" https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}