summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-07-30 14:59:52 +0200
committerZac Medico <zmedico@gentoo.org>2024-07-30 20:06:57 -0700
commit347cfef6bae84210b9828345ff2300d6789d33aa (patch)
treeb567fee906a4717bb37fbd465e4828ad6c67a2ba /sys-apps
parentdev-util/gitlab-runner: drop 16.11.2 (diff)
downloadgentoo-347cfef6bae84210b9828345ff2300d6789d33aa.tar.gz
gentoo-347cfef6bae84210b9828345ff2300d6789d33aa.tar.bz2
gentoo-347cfef6bae84210b9828345ff2300d6789d33aa.zip
sys-apps/yarn: drop old
Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/37815 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/yarn/Manifest3
-rw-r--r--sys-apps/yarn/yarn-1.22.17.ebuild40
-rw-r--r--sys-apps/yarn/yarn-1.22.19.ebuild40
-rw-r--r--sys-apps/yarn/yarn-1.22.21.ebuild40
4 files changed, 0 insertions, 123 deletions
diff --git a/sys-apps/yarn/Manifest b/sys-apps/yarn/Manifest
index b3e157667ab3..77b9534a1b56 100644
--- a/sys-apps/yarn/Manifest
+++ b/sys-apps/yarn/Manifest
@@ -1,4 +1 @@
-DIST yarn-v1.22.17.tar.gz 1246198 BLAKE2B ae0b86cdb248a0f81d1a4a23d15ef9aab185fcda7ef7f8873959c3e54dfc305219afb2416264911098c4e3a6a65a33d248ff97c8e0ca043b118de64e003c3d9b SHA512 1f4a76e35057687d1437d21e1fffd14fcdad9793df36b695a52a44a16f844fb966a29342eb5799f80f880ef53c14ce86a39bf1d7ad929dc0cbf09d598d106b89
-DIST yarn-v1.22.19.tar.gz 1244259 BLAKE2B f103d148bafa76bddcdf9e26356fbebba87f7c7c707f823a54404302571e1d09e25569406fc721d74f53cfdac8706dec6bd40da39b7d44000381b1f36d0d8de0 SHA512 ff4579ab459bb25aa7c0ff75b62acebe576f6084b36aa842971cf250a5d8c6cd3bc9420b22ce63c7f93a0857bc6ef29291db39c3e7a23aab5adfd5a4dd6c5d71
-DIST yarn-v1.22.21.tar.gz 1243124 BLAKE2B 99a53db799f07c6aed1bb8d5d2997b6caef6d518118ef8bea4974fdaf3cc0b6a7a7fa17fb9244c8fb2915bffed77d5ed8dd701eecdcf4491d26b68f92750d8c7 SHA512 75fc33d00ee14733272c04090b3a646fb4021fce85103b2451f01f60f47be7dc9811c76b26465fe6a3735996ac55fd9e80f918cc45422af0888047f4c9ba8f9d
DIST yarn-v1.22.22.tar.gz 1247457 BLAKE2B a81ec778e774f85da6d5802d4abbc579f1c9194f6e2681ef239cc336e4ec2b502b412f303fa4a8c61dda08a00444e120487e04aa19e89113f844c0db4fd54098 SHA512 c8b361ca353e3ca15e32eadf7f1617449f485fe488860e49774ea35dac1544f39ab1104f82bf24528de6e553eef53c4604a560e522dfab8433425ee13ccfd6f9
diff --git a/sys-apps/yarn/yarn-1.22.17.ebuild b/sys-apps/yarn/yarn-1.22.17.ebuild
deleted file mode 100644
index bb8df23d1c0e..000000000000
--- a/sys-apps/yarn/yarn-1.22.17.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P="${PN}-v${PV}"
-
-DESCRIPTION="Fast, reliable, and secure node dependency management"
-HOMEPAGE="https://yarnpkg.com"
-SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~x86"
-IUSE=""
-
-RDEPEND="!dev-util/cmdtest
- net-libs/nodejs"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
- sed -i 's/"installationMethod": "tar"/"installationMethod": "portage"/g' "${S}/package.json" || die
-}
-
-src_install() {
- local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
- insinto "${install_dir}"
- doins -r .
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarnpkg" "/usr/bin/yarnpkg"
-
- while read -r -d '' path; do
- read -r shebang < "${ED}${path}" || die
- [[ "${shebang}" == \#\!* ]] || continue
- fperms +x "${path}"
- done < <(find "${ED}" -type f -printf '/%P\0' || die)
-}
diff --git a/sys-apps/yarn/yarn-1.22.19.ebuild b/sys-apps/yarn/yarn-1.22.19.ebuild
deleted file mode 100644
index a1a20e84d28e..000000000000
--- a/sys-apps/yarn/yarn-1.22.19.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P="${PN}-v${PV}"
-
-DESCRIPTION="Fast, reliable, and secure node dependency management"
-HOMEPAGE="https://yarnpkg.com"
-SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~x86"
-IUSE=""
-
-RDEPEND="!dev-util/cmdtest
- net-libs/nodejs"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
- sed -i 's/"installationMethod": "tar"/"installationMethod": "portage"/g' "${S}/package.json" || die
-}
-
-src_install() {
- local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
- insinto "${install_dir}"
- doins -r .
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarnpkg" "/usr/bin/yarnpkg"
-
- while read -r -d '' path; do
- read -r shebang < "${ED}${path}" || die
- [[ "${shebang}" == \#\!* ]] || continue
- fperms +x "${path}"
- done < <(find "${ED}" -type f -printf '/%P\0' || die)
-}
diff --git a/sys-apps/yarn/yarn-1.22.21.ebuild b/sys-apps/yarn/yarn-1.22.21.ebuild
deleted file mode 100644
index 02435ca2eafe..000000000000
--- a/sys-apps/yarn/yarn-1.22.21.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_P="${PN}-v${PV}"
-
-DESCRIPTION="Fast, reliable, and secure node dependency management"
-HOMEPAGE="https://yarnpkg.com"
-SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE=""
-
-RDEPEND="!dev-util/cmdtest
- net-libs/nodejs"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
- sed -i 's/"installationMethod": "tar"/"installationMethod": "portage"/g' "${S}/package.json" || die
-}
-
-src_install() {
- local install_dir="/usr/$(get_libdir)/node_modules/yarn" path shebang
- insinto "${install_dir}"
- doins -r .
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarnpkg" "/usr/bin/yarnpkg"
-
- while read -r -d '' path; do
- read -r shebang < "${ED}${path}" || die
- [[ "${shebang}" == \#\!* ]] || continue
- fperms +x "${path}"
- done < <(find "${ED}" -type f -printf '/%P\0' || die)
-}