summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-07 21:02:20 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-07 21:02:20 +0200
commit214e57f5eb11f3f00dd62246cb7b3085e0b958d0 (patch)
treeb9421b354d0b249c269c6cec693d3c4592a68563 /sys-apps/smartmontools
parentEAPI=6 support; removed support befor media-video/vdr-2 (diff)
downloadgentoo-214e57f5eb11f3f00dd62246cb7b3085e0b958d0.tar.gz
gentoo-214e57f5eb11f3f00dd62246cb7b3085e0b958d0.tar.bz2
gentoo-214e57f5eb11f3f00dd62246cb7b3085e0b958d0.zip
sys-apps/smartmontools: Bump to version 6.5
Synced live ebuild. Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/Manifest1
-rw-r--r--sys-apps/smartmontools/metadata.xml1
-rw-r--r--sys-apps/smartmontools/smartmontools-6.5.ebuild99
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild46
4 files changed, 127 insertions, 20 deletions
diff --git a/sys-apps/smartmontools/Manifest b/sys-apps/smartmontools/Manifest
index 66f21cdea3a1..6ca4e0b4e1a9 100644
--- a/sys-apps/smartmontools/Manifest
+++ b/sys-apps/smartmontools/Manifest
@@ -1 +1,2 @@
DIST smartmontools-6.4.tar.gz 822539 SHA256 eab75600c1eda9c34b13097db71138ab376f3dad8a6a4667fb4d1d081feb7a85 SHA512 366cd55ec668da1ca8a3d9ba79d5bee6e0c59032936b7f2f161f8fbb1c9f869c505d715cc10562b6241f808bb8b534feaf9d9fd752f6cb1593ee893611742adc WHIRLPOOL 72af8a0a4754bd75da9e98a008c64c083579fe27bdbd0655da81c8fe7a258dbc305cafd05f2f21d1954918ab8ff040cf1d54b916a1ce82fb8da64ba2e49b4de0
+DIST smartmontools-6.5.tar.gz 855642 SHA256 89e8bb080130bc6ce148573ba5bb91bfe30236b64b1b5bbca26515d4b5c945bc SHA512 dca7a6363ab7280ee4197155025f624c978886dcc94fc47b524f6f849138b62c471e966c0d4bf59c7bba50519dc122264618e5ded80a406863ddd10b43d928d3 WHIRLPOOL 639bb5c847c4e0e0f7156b764140f4382f650826eb3d59db6a712468e944a40788c87bbbe0149b9a4d1480947492b007b5875969e611213409f247ff4383fbd6
diff --git a/sys-apps/smartmontools/metadata.xml b/sys-apps/smartmontools/metadata.xml
index 997fef21c2a4..b35558848001 100644
--- a/sys-apps/smartmontools/metadata.xml
+++ b/sys-apps/smartmontools/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="minimal">Do not install the monitoring daemon and associated scripts.</flag>
+ <flag name="update_drivedb">Install a script to update the drivedb file.</flag>
</use>
<upstream>
<remote-id type="sourceforge">smartmontools</remote-id>
diff --git a/sys-apps/smartmontools/smartmontools-6.5.ebuild b/sys-apps/smartmontools/smartmontools-6.5.ebuild
new file mode 100644
index 000000000000..ff70dcf2c079
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-6.5.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic systemd
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
+ ESVN_PROJECT="smartmontools"
+ inherit subversion autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~x64-macos"
+fi
+
+DESCRIPTION="Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.) monitoring tools"
+HOMEPAGE="https://www.smartmontools.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps minimal selinux static update_drivedb"
+
+DEPEND="
+ caps? (
+ static? ( sys-libs/libcap-ng[static-libs] )
+ !static? ( sys-libs/libcap-ng )
+ )
+ selinux? (
+ sys-libs/libselinux
+ )"
+RDEPEND="${DEPEND}
+ !minimal? ( virtual/mailx )
+ selinux? ( sec-policy/selinux-smartmon )
+"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use minimal && einfo "Skipping the monitoring daemon for minimal build."
+ use static && append-ldflags -static
+ # The build installs /etc/init.d/smartd, but we clobber it
+ # in our src_install, so no need to manually delete it.
+ myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --with-drivedbdir=/var/db/${PN} #575292
+ --with-initscriptdir="${EPREFIX}/etc/init.d"
+ $(use_with caps libcap-ng)
+ $(use_with selinux)
+ $(systemd_with_unitdir)
+ $(use_with update_drivedb update-smart-drivedb)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local db_path="/var/db/${PN}"
+
+ if use minimal ; then
+ dosbin smartctl
+ doman smartctl.8
+ else
+ default
+ newinitd "${FILESDIR}"/smartd-r1.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+
+ keepdir ${db_path}
+ if use update_drivedb ; then
+ # Move drivedb.h file out of PM's sight (bug #575292)
+ mv "${ED}"${db_path}/drivedb.h "${T}" || die
+
+ exeinto /etc/cron.monthly
+ doexe "${FILESDIR}"/${PN}-update-drivedb
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if ! use minimal ; then
+ local db_path="/var/db/${PN}"
+
+ if [[ -f "${db_path}/drivedb.h" ]] ; then
+ ewarn "WARNING! The drive database file has been replaced with the version that"
+ ewarn "got shipped with this release of ${PN}. You may want to update the"
+ ewarn "database by running the following command as root:"
+ ewarn ""
+ ewarn "/usr/sbin/update-smart-drivedb"
+ fi
+
+ if use update_drivedb ; then
+ # Move drivedb.h to /var/db/${PN} (bug #575292)
+ mv "${T}"/drivedb.h ${db_path} || die
+ fi
+ fi
+}
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index 9b4bce3b1fa3..ff70dcf2c079 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://www.smartmontools.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="caps minimal selinux static"
+IUSE="caps minimal selinux static update_drivedb"
DEPEND="
caps? (
@@ -35,10 +35,6 @@ RDEPEND="${DEPEND}
"
src_prepare() {
- # 580424
- sed '/^SRCEXPR/s@http:@https:@' \
- -i update-smart-drivedb.in \
- || die
if [[ ${PV} == "9999" ]] ; then
eautoreconf
fi
@@ -56,11 +52,14 @@ src_configure() {
$(use_with caps libcap-ng)
$(use_with selinux)
$(systemd_with_unitdir)
+ $(use_with update_drivedb update-smart-drivedb)
)
econf "${myeconfargs[@]}"
}
src_install() {
+ local db_path="/var/db/${PN}"
+
if use minimal ; then
dosbin smartctl
doman smartctl.8
@@ -68,26 +67,33 @@ src_install() {
default
newinitd "${FILESDIR}"/smartd-r1.rc smartd
newconfd "${FILESDIR}"/smartd.confd smartd
- fi
- # Move drivedb.h file out of PM's sight (bug #575292)
- mv "${ED}"/var/db/${PN}/drivedb.h "${T}" || die
+ keepdir ${db_path}
+ if use update_drivedb ; then
+ # Move drivedb.h file out of PM's sight (bug #575292)
+ mv "${ED}"${db_path}/drivedb.h "${T}" || die
- exeinto /etc/cron.monthly
- doexe "${FILESDIR}"/${PN}-update-drivedb
+ exeinto /etc/cron.monthly
+ doexe "${FILESDIR}"/${PN}-update-drivedb
+ fi
+ fi
}
pkg_postinst() {
- local db_path="/var/db/${PN}"
+ if ! use minimal ; then
+ local db_path="/var/db/${PN}"
- if [[ -f "${db_path}/drivedb.h" ]] ; then
- ewarn "WARNING! The drive database file has been replaced with the version that"
- ewarn "got shipped with this release of ${PN}. You may want to update the"
- ewarn "database by running the following command as root:"
- ewarn ""
- ewarn "/usr/sbin/update-smart-drivedb"
- fi
+ if [[ -f "${db_path}/drivedb.h" ]] ; then
+ ewarn "WARNING! The drive database file has been replaced with the version that"
+ ewarn "got shipped with this release of ${PN}. You may want to update the"
+ ewarn "database by running the following command as root:"
+ ewarn ""
+ ewarn "/usr/sbin/update-smart-drivedb"
+ fi
- # Move drivedb.h to /var/db/${PN} (bug #575292)
- mv "${T}"/drivedb.h ${db_path} || die
+ if use update_drivedb ; then
+ # Move drivedb.h to /var/db/${PN} (bug #575292)
+ mv "${T}"/drivedb.h ${db_path} || die
+ fi
+ fi
}