summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-16 00:14:58 +0100
committerSam James <sam@gentoo.org>2023-06-16 00:14:58 +0100
commitd7c9016f4914aff3b07f239e76bd74cc603288dc (patch)
tree810f2a8a28dceeb67b94ceb4246bcf0f6ea45d81 /sys-apps/goawk
parenttoolchain.eclass: support --enable-host-pie for GCC 14 (diff)
downloadgentoo-d7c9016f4914aff3b07f239e76bd74cc603288dc.tar.gz
gentoo-d7c9016f4914aff3b07f239e76bd74cc603288dc.tar.bz2
gentoo-d7c9016f4914aff3b07f239e76bd74cc603288dc.zip
sys-apps/goawk: add 1.23.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/goawk')
-rw-r--r--sys-apps/goawk/Manifest1
-rw-r--r--sys-apps/goawk/goawk-1.23.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/goawk/Manifest b/sys-apps/goawk/Manifest
index 3738f8c276aa..2a37ef963f8b 100644
--- a/sys-apps/goawk/Manifest
+++ b/sys-apps/goawk/Manifest
@@ -1,2 +1,3 @@
DIST goawk-1.23.1.tar.gz 1678471 BLAKE2B f87037cdb5f256d5c3848f7fb0e64d81672abfa03c15d9b778fac14804c252ea140b3b436a09ab2189364b180bd1b638ecd66e767dd72532cc0f051ca2255097 SHA512 64f56f5ffa512929aa83d4df0360894ef231fdffe1879a72ed723606db77bf001ee744b646221a6042ef2cd3cb79fc8c80e33cec992b0b8c61da9f41ba78650b
DIST goawk-1.23.2.tar.gz 1682245 BLAKE2B 6f7c87717ae3539272688c600705ca9757f38671dd2d73688ff4b3e345d66e2cf7b16f7bc6d0dd97340cf84b8a09bb116207ec5dfb361ff5721ffe99c048c118 SHA512 b448b99cb880b23de72fc77948217291b9da6733ad8538d7978e3dbd83e233ac6c558a39bc7d995002bb6b67c6b6ed5ac3a4131b90f43443bdd7c639b793f5ee
+DIST goawk-1.23.3.tar.gz 1682899 BLAKE2B e0ca6001b5adc78186549cbf11bc016294a996e8a1337227a1915e30b5f04786cf443c19c8daaae5e4e0604945783bc89a4a173f1f878685f7330f4f3933690e SHA512 06955b9cf53ac7a4a414ea18b4886fa71f1ec3ca1338a6648f9650f28ba5f52d672eddb7b5f8462fb404966b716f9a1ac8b6e075ab74883e6d1ad1a16314f4f8
diff --git a/sys-apps/goawk/goawk-1.23.3.ebuild b/sys-apps/goawk/goawk-1.23.3.ebuild
new file mode 100644
index 000000000000..e138a7adbd3d
--- /dev/null
+++ b/sys-apps/goawk/goawk-1.23.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="POSIX-compliant AWK interpreter written in Go, with CSV support"
+HOMEPAGE="https://github.com/benhoyt/goawk"
+SRC_URI="https://github.com/benhoyt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+src_compile() {
+ ego build
+}
+
+src_test() {
+ ego test
+}
+
+src_install() {
+ einstalldocs
+
+ dobin goawk
+}