summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Schultz <mattsch@gmail.com>2018-01-08 12:04:48 -0600
committerMichał Górny <mgorny@gentoo.org>2018-03-13 20:16:25 +0100
commit6d7c9bc973e172a940251f8b39c9e446a713ad0c (patch)
tree6ce36c2d34b44f8eafee0e856ba3a8a3e63d5f46 /sys-apps/biosdisk/biosdisk-0_p20171116.ebuild
parentsys-apps/paludis: amd64 stable wrt bug #643056 (diff)
downloadgentoo-6d7c9bc973e172a940251f8b39c9e446a713ad0c.tar.gz
gentoo-6d7c9bc973e172a940251f8b39c9e446a713ad0c.tar.bz2
gentoo-6d7c9bc973e172a940251f8b39c9e446a713ad0c.zip
sys-apps/biosdisk: version bump to 20171116 git commit.
Bumped to most recent git commit by date. Changed the repo to github since it no longer exists on dell.com. (bug #619968) Bug: https://bugs.gentoo.org/619968 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-apps/biosdisk/biosdisk-0_p20171116.ebuild')
-rw-r--r--sys-apps/biosdisk/biosdisk-0_p20171116.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/biosdisk/biosdisk-0_p20171116.ebuild b/sys-apps/biosdisk/biosdisk-0_p20171116.ebuild
new file mode 100644
index 000000000000..87367d63b19d
--- /dev/null
+++ b/sys-apps/biosdisk/biosdisk-0_p20171116.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+EGIT_COMMIT="f534dd22a795dca9c42f44b52f206bf02eadb682"
+DESCRIPTION="A script that creates floppy boot images to flash Dell BIOSes"
+HOMEPAGE="https://github.com/dell/biosdisk"
+SRC_URI="https://github.com/dell/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=app-text/dos2unix-5.0
+ sys-boot/syslinux
+ ${PYTHON_DEPS}
+"
+
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+src_install() {
+ python_fix_shebang blconf
+
+ dosbin biosdisk blconf
+
+ dodoc AUTHORS README README.dosdisk TODO VERSION
+ gunzip biosdisk.8.gz || die
+ doman biosdisk.8
+
+ insinto /usr/share/biosdisk
+ doins dosdisk.img dosdisk{288,8192,20480}.img biosdisk-mkrpm-{fedora,redhat,generic}-template.spec
+
+ insinto /etc
+ doins biosdisk.conf
+}