summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-04 21:19:28 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-04 23:05:44 +0000
commit7f6bad05f12b10dd435737dd06778bf8ba9f4573 (patch)
tree1896dfb388a3ca3bdc6ff066c3cf6240a74896cb /sci-visualization/yt/yt-3.3.5.ebuild
parentdev-python/astroquery: version bump (diff)
downloadgentoo-7f6bad05f12b10dd435737dd06778bf8ba9f4573.tar.gz
gentoo-7f6bad05f12b10dd435737dd06778bf8ba9f4573.tar.bz2
gentoo-7f6bad05f12b10dd435737dd06778bf8ba9f4573.zip
sci-visualization/yt: version bump. switch to sci-astronomy
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-visualization/yt/yt-3.3.5.ebuild')
-rw-r--r--sci-visualization/yt/yt-3.3.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-visualization/yt/yt-3.3.5.ebuild b/sci-visualization/yt/yt-3.3.5.ebuild
new file mode 100644
index 000000000000..4161ab6488b1
--- /dev/null
+++ b/sci-visualization/yt/yt-3.3.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Astrophysical Simulation Analysis and Vizualization package"
+HOMEPAGE="http://yt-project.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ >=dev-python/cython-0.24[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-20.0[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ append-flags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ nosetests -sv --exclude=test_flake8 || die "Tests fail with ${EPYTHON} ${PWD}"
+ popd >/dev/null || die
+}