summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-09-27 10:07:38 +0200
committerGuilherme Amadio <amadio@gentoo.org>2019-09-27 15:40:45 +0200
commite912bed98474f247e78205f2eaf741fd765e65fb (patch)
treee66e979dfc09042d3b5d5b2f8775b8eb55e4749b /sci-physics/lhapdf
parentx11-themes/gargantuan-icon-theme: gnome2-utils => xdg-utils (diff)
downloadgentoo-e912bed98474f247e78205f2eaf741fd765e65fb.tar.gz
gentoo-e912bed98474f247e78205f2eaf741fd765e65fb.tar.bz2
gentoo-e912bed98474f247e78205f2eaf741fd765e65fb.zip
sci-physics/lhapdf: version bump to 6.2.3 and use EAPI 7
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/lhapdf')
-rw-r--r--sci-physics/lhapdf/Manifest1
-rw-r--r--sci-physics/lhapdf/lhapdf-6.2.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-physics/lhapdf/Manifest b/sci-physics/lhapdf/Manifest
index 2da636da50b3..3b9cfcd16c72 100644
--- a/sci-physics/lhapdf/Manifest
+++ b/sci-physics/lhapdf/Manifest
@@ -1,5 +1,6 @@
DIST CT10.LHgrid 21081519 BLAKE2B 29d984a010405de5537d27eca81a306ea4dfc13b554d96031a087cdb9105ce65d736ef6e65f5a1ed3121ad22a6e0bc855ad5a16905b10e214405d9fcc8b39ae5 SHA512 4196b0899dc7f5803608d9328872b942393d5f5103e8d50a53b35af6f8bac509adbbe83c363ab33a5fbfab3c33156e8ae46131939ad5a8642c558ff209630820
DIST LHAPDF-6.1.6.tar.gz 696608 BLAKE2B 7d416b3a278544ab5b672b7f1b4dd7dd00dd8597acc822f6efbdf74708c2549672de3983397fce5ab95ddf6319fa2cfd0c4b23bc9451d1708468367ecf9ae7ec SHA512 371a4062d3f1a4d611d8c09950a1ba7b747df29f04502a1ab9c420c300799143a53eebdecd04293d38b2c481b525c2414ac0fb8e2f8846de65e07992dea18656
+DIST LHAPDF-6.2.3.tar.gz 750659 BLAKE2B a16f67c69f41e96cdb5434cc53658c6b085b94c9ad06443fdfb49aa1de50eeb2a59aa41442a032c29b361bad4f749cef42499f3d16f2774efb0b399f889576e4 SHA512 167064a141f46e5c834d950690a989330b940acec62377b8b4c40e14665503cf7b4ddb79e05c71ebe1f801231192d951e294bec3944ec37b2bca484b2e5ce894
DIST MRST2004nlo.LHgrid 288040 BLAKE2B b568b94905370faa30bbb8ad5ae9b8ee0938fb1373c19ca823662e6f7c930d251734d4afa72c8679b06356999b36bfd828749cbc9dc86a493a1764cb07cf0871 SHA512 b554454fa494c86a3ae56168c3d74c5e3c3bd80f10b393153c0adfbb39a3f3837ae2db80534d288784409154034187c9c5212dfc9c21ed1bf32ef89b9266e262
DIST cteq5l.LHgrid 134797 BLAKE2B 1e222631ff00979abf64e95ffa3133d29eacd819325fcdf9d4065a1ce85db5704f0a43c646f9a9a3ee7b1905603e9060fc279405435d412bf06ee14ba9121f32 SHA512 1ba41fd773104a933af6f37745dcb6f8422e1aece74ba2b1e15a5fb69fdaf694336c0ec1dc6fbc964d2cf3fe363d17ca0c01a6c2ba6def0afa4389cb4083f34b
DIST cteq61.LHgrid 8946864 BLAKE2B aa7d7d817082a70fb53cf9c9d367af3bca9b5f4d845ee6c8f8b77265541980cab6f6ffc74a2233ef2899c161f9171cb3e7ba9570a57c5ed048311622217f8e89 SHA512 ab35c058f1ece8b428d8664ba2e14068541279328b5eb9e13b020642cc804c21f7412414dd74bb3621a5136bfa7d9a60832604c944d1e3519c5a94d3dce2a063
diff --git a/sci-physics/lhapdf/lhapdf-6.2.3.ebuild b/sci-physics/lhapdf/lhapdf-6.2.3.ebuild
new file mode 100644
index 000000000000..f55cef4113b9
--- /dev/null
+++ b/sci-physics/lhapdf/lhapdf-6.2.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+MY_PV=$(ver_cut 1-3)
+MY_PF=LHAPDF-${MY_PV}
+
+DESCRIPTION="Les Houches Parton Density Function unified library"
+HOMEPAGE="http://lhapdf.hepforge.org/"
+SRC_URI="http://www.hepforge.org/archive/lhapdf/${MY_PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:0=
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex] )"
+
+S="${WORKDIR}/${MY_PF}"
+
+src_configure() {
+ econf $(use_enable python)
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_prepare
+ fi
+}
+
+src_compile() {
+ emake all $(use doc && echo doxy)
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ emake -C tests
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use doc && dodoc -r doc/doxygen/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.cc
+ fi
+ if use python; then
+ cd "${S}/wrappers/python" && distutils-r1_src_install
+ fi
+}
+
+pkg_postinst() {
+ elog "Download data files from:"
+ elog "http://www.hepforge.org/archive/${PN}/pdfsets/$(ver_cut 1-2)"
+ elog "and untar them into ${EPREFIX}/usr/share/LHAPDF"
+}