summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-05-22 15:36:38 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-05-22 16:05:15 -0400
commit7b1b2bdcbdb28ec852606196f6acde8731ce6387 (patch)
tree639854b2000941148301df240fdc6d84e6e6d6d2 /sci-mathematics/plfit
parentdev-libs/libclc: Enable USE=spirv by default (diff)
downloadgentoo-7b1b2bdcbdb28ec852606196f6acde8731ce6387.tar.gz
gentoo-7b1b2bdcbdb28ec852606196f6acde8731ce6387.tar.bz2
gentoo-7b1b2bdcbdb28ec852606196f6acde8731ce6387.zip
sci-mathematics/plfit: new package, add 0.9.3
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/plfit')
-rw-r--r--sci-mathematics/plfit/Manifest1
-rw-r--r--sci-mathematics/plfit/metadata.xml13
-rw-r--r--sci-mathematics/plfit/plfit-0.9.3.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/sci-mathematics/plfit/Manifest b/sci-mathematics/plfit/Manifest
new file mode 100644
index 000000000000..03611001ad5e
--- /dev/null
+++ b/sci-mathematics/plfit/Manifest
@@ -0,0 +1 @@
+DIST plfit-0.9.3.tar.gz 178880 BLAKE2B 611c4d30fa39cb05f8324670c484fd504abf2b1638602f5fede31438bf831f8aa3d7f3a5c6f2edbab377c99bf5f67763149f288581778fdd2fe9a1596a0d4a23 SHA512 6ca0fab75f607b27801576ff6752002079e11c736d0c3f6a669f20bb2869a254aa3ba124a5f6df1ad1daed25c59c8b0952838478cd42570e6d399958f0796e84
diff --git a/sci-mathematics/plfit/metadata.xml b/sci-mathematics/plfit/metadata.xml
new file mode 100644
index 000000000000..fad11365ac2d
--- /dev/null
+++ b/sci-mathematics/plfit/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ntamas/plfit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/plfit/plfit-0.9.3.ebuild b/sci-mathematics/plfit/plfit-0.9.3.ebuild
new file mode 100644
index 000000000000..f5c15c46b845
--- /dev/null
+++ b/sci-mathematics/plfit/plfit-0.9.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fit power-law distributions to empirical data"
+HOMEPAGE="https://github.com/ntamas/plfit"
+SRC_URI="https://github.com/ntamas/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+# plfit is gpl-2 and its source headers say "or later." The upstream
+# doc/ directory contains MIT and BSD licenses for two components.
+LICENSE="BSD GPL-2+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse cpu_flags_x86_sse2"
+
+DOCS=( CHANGELOG.md README.rst doc/THANKS )
+
+src_configure() {
+ local mycmakeargs=(
+ -DPLFIT_COMPILE_PYTHON_MODULE=OFF
+ -DPLFIT_USE_SSE=OFF
+ -DPLFIT_USE_OPENMP=OFF
+ )
+ if use cpu_flags_x86_sse || use cpu_flags_x86_sse2; then
+ # plfit chooses which to use at compile time based on the
+ # constants __SSE__ and __SSE2__.
+ mycmakeargs+=( -DPLFIT_USE_SSE=ON )
+ fi
+ cmake_src_configure
+}