summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-26 16:19:38 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-26 16:41:22 +0100
commitc544a910fcb78324a9001fbe6c1bc4931e47c21f (patch)
tree0887e577fd6c390d6eb876247b383faf686655f6 /sci-mathematics/minisat
parentapp-text/libexttextcat: Drop 3.4.5 (diff)
downloadgentoo-c544a910fcb78324a9001fbe6c1bc4931e47c21f.tar.gz
gentoo-c544a910fcb78324a9001fbe6c1bc4931e47c21f.tar.bz2
gentoo-c544a910fcb78324a9001fbe6c1bc4931e47c21f.zip
sci-mathematics/minisat: bump to 2.2.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/minisat')
-rw-r--r--sci-mathematics/minisat/Manifest1
-rw-r--r--sci-mathematics/minisat/metadata.xml31
-rw-r--r--sci-mathematics/minisat/minisat-2.2.1.ebuild29
3 files changed, 54 insertions, 7 deletions
diff --git a/sci-mathematics/minisat/Manifest b/sci-mathematics/minisat/Manifest
index 4f851e3ea3c4..672e6b24bfa1 100644
--- a/sci-mathematics/minisat/Manifest
+++ b/sci-mathematics/minisat/Manifest
@@ -1,2 +1,3 @@
DIST MiniSat.pdf 327416 BLAKE2B 77f77d763c9554680b4c5e1688801e8462102e8ddbcc3b53badccee17a98f935ef0e971a636abeb04021a2b3a3e9d6acfe4828b5dd20e6ef8733d71788cc31b0 SHA512 94e70c721740c0b7fd52621c7a5e43dd9207eed92e60a1c64ee63b541b9861d2580d14ba64c49c6c4f273ac028ded43bc944c71131e51693cdd7d1763af582f6
DIST minisat-2.2.0_p20130925.tar.gz 49544 BLAKE2B 8c6893fb6c604140609c36cc912c02a73c1f2726d7f399595c50d674aff69c57f9c4914da6d95c37a46fefc218dd4b0550645bd7058d46640d08103e2a4ec333 SHA512 37fc35cc4f3104d7f0e8ee9f7123fc34e175df578658266799d809d71d6cf081e811919f304a02f6cb9c3827d308e59408149d63d1d1e7c6d0b495350f93b3d9
+DIST minisat-2.2.1.tar.gz 50485 BLAKE2B 58c292f0b90dd459fa29fadbf9e2b20106406c08df9ce98f40138b12a8f001b4ab72f661815d1254c6c90158c3d6e3df339c784552605a935ebc5e703b2d8768 SHA512 a69734e1a70fe056f9dfd479fe4e6e25bc418d3631c1c2d0dea1190ffe9f86b1fc5e9aabaf3772a752fe654551f1e84e47fcb8655f6fe25176efc8d8bc96c663
diff --git a/sci-mathematics/minisat/metadata.xml b/sci-mathematics/minisat/metadata.xml
index 970536799081..812aa0c09202 100644
--- a/sci-mathematics/minisat/metadata.xml
+++ b/sci-mathematics/minisat/metadata.xml
@@ -1,11 +1,28 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">niklasso/minisat</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ MiniSat is a minimalistic, open-source SAT solver, developed to help
+ researchers and developers alike to get started on SAT. It is released
+ under the MIT licence, and is currently used in a number of projects.
+ MiniSat is small and well-documented, and possibly also well-designed,
+ making it an ideal starting point for adapting SAT based techniques to
+ domain specific problems.
+ Winning all the industrial categories of the SAT 2005 competition, MiniSat
+ is a good starting point both for future research in SAT, and for
+ applications using SAT.
+ MiniSat supports incremental SAT and has mechanisms for adding non-clausal
+ constraints. By virtue of being easy to modify, it is a good choice for
+ integrating as a backend to another tool, such as a model checker or a more
+ generic constraint solver.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">niklasso/minisat</remote-id>
+ <remote-id type="github">stp/minisat</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sci-mathematics/minisat/minisat-2.2.1.ebuild b/sci-mathematics/minisat/minisat-2.2.1.ebuild
new file mode 100644
index 000000000000..360c5a33082b
--- /dev/null
+++ b/sci-mathematics/minisat/minisat-2.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Small yet efficient SAT solver with reference paper"
+HOMEPAGE="http://minisat.se/Main.html"
+SRC_URI="https://github.com/stp/${PN}/archive/releases/${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( http://minisat.se/downloads/MiniSat.pdf )"
+S="${WORKDIR}/${PN}-releases-${PV}"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+IUSE="doc"
+
+RDEPEND="sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ cmake_src_install
+
+ mv "${D}"/usr/lib "${D}"/usr/$(get_libdir) || die
+ dosym libminisat.a /usr/$(get_libdir)/libMiniSat.a
+
+ use doc && dodoc "${DISTDIR}"/MiniSat.pdf
+}